Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

While writing a word document (office 2007) I added a figure. Then i right-clicked on it and selected "add caption". You then get a little box in which you can add some text. The box comes containing the test "Figure X" and you enter your text directly after the number X. I added the text "is an enlargment of Figure 2". Then Word did something which I can't recover from. Did it not like the word Figure in the caption and got confused? This is what it looks like:enter image description here

All views except "Draft" look sort of like this. Selecting draft I see the document, but everything is marked. I can't unmark it and whatever I do it starts adding things to the clipboard. Emptying the clipboard doesn't help, closing word and starting it again doesn't help.

Please please can someone tell me how to get out of this mysterious mode!

share|improve this question
    
Can we assume that you've tried all of the minimize/restore, or close/open the file, or reboot the machine type steps? –  jonsca May 16 '11 at 9:38
    
Yes you can assume that. –  AnnaR May 16 '11 at 10:39
    
I was not able to reproduce it. I tried Word 2007, compatibility mode, 2 figures that referenced each other or non-existent figures. The only thing I got that looked anything remotely like that was when I turned on gridlines in the View tab, but yours don't have any horizontal lines. You could try writing a macro to step through the elements and delete the offending text (and use Fig. instead lol). –  jonsca May 16 '11 at 11:02
    
I am not sure that adding a figure caption is the key to this "mode". I can't redo it either. God knows what happened. But the fact remains, I have a document looking like the picture and I want to salvage it! –  AnnaR May 16 '11 at 12:42
    
Have you tried opening the file on another machine? Would help to narrow it down to being either your installation, or the individual file. Can you open other word docs OK? –  Jaymz May 16 '11 at 14:59
show 3 more comments

4 Answers

As it's running in compatability mode, I'm assuming it's a .doc binary file, rather than the newer .docx xml based files...

Can you do a File | Save As, and save it as a .docx file format?

Once it's saved as a .docx, even if opening it still yields the same corrupt format as above, you should be able to open the docx container (as a zip file), and view the individual files inside. From there, you may be able to correct the issue - whatever that may be.

share|improve this answer
    
Good idea, but unfortunately it doesn't help. –  AnnaR May 17 '11 at 10:08
    
Did you open the file as a zip file? Open it with 7-zip or WinZip or whatever, and you'll see 3 folders inside. Check inside the word folder - you'll find the main document.xml file along with many others. Check some of those out for the "Figure" text, and see if you can remove it. –  Jaymz May 17 '11 at 10:18
add comment

I would just revert to the previous backup copy and redo the changes.

If I have to work with MS Word, I usually save the document to new file with new name with "save as" function every 30-60 minutes or so. Because it's just matter of time when Word does something strange where recovery is hard or impossible.

share|improve this answer
add comment

User settings

It can be user settings. To check it, try using another user account. If the problem does not occur with it, try it:

  • Go to application data folder (in Windows XP: c:\documents and settings\AnnaLR\Application data\Microsoft ; in Windows Vista/7: c:\user\AnnaLR\Appdata\Roaming\Microsoft)
  • Rename Office and Word folders to Office.old and Word.old
  • Run M$ Word again to check if the problem disappears.

An alternative way

If you want to finish that particular work: use another software. Try OpenOffice / LibreOffice.

share|improve this answer
add comment

I met with the same problem in Word 2010. Try this: Open the document, click Microsoft button->add-in->manage->template->go to->The global template and add-in->delete WordCmds.dot the name of those button may not be exactly right, because Word in my laptop is in Chinese. I hope that would help.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.