Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using Ubuntu 11.04; when I move a window partially offscreen, the offscreen part shows on the next/previous desktop

In the screenshot below you can see CompizConfig (opened on the second desktop) is moved off-screen a bit and partially shows on this desktop.

enter image description here

Where can I turn this off?

share|improve this question
    
This is how multiple monitor desktops always work. What would you like to happen instead? –  rjmunro May 16 '11 at 13:45
    
I want it to go offscreen. at least to have an outer border on the multiple desktops so when I am on the TOP RIGHT desktop, and move the window offscreen to the RIGHT I don't want it to show on the TOP LEFT screen from the LEFT –  kalkulus May 16 '11 at 13:51
    
So it's wrapping around the multiple monitors? Does the cursor wrap round along with the windows? Or is it just the Windows? –  Jaymz May 16 '11 at 14:28
1  
it's not multiple monitors, it's one monitor with virtual desktops. when I move the window offscreen on one virtual desktop it shows on the other one. maybe I wasn't clear enough, sorry –  kalkulus May 16 '11 at 14:37
1  
Ah, ok, sorry, rjmunro's comment threw me. If you run a 2x2 grid, does it also happen vertically? Seems to be a known bug/feature: bugs.launchpad.net/ubuntu/+source/compiz/+bug/480228 –  Jaymz May 16 '11 at 14:43

2 Answers 2

This is the window manager's fault. Metacity doesn't have a way to control this, but other window managers may.

share|improve this answer

See http://earlruby.org/2012/04/getting-rid-of-self-resizing-windows-in-ubuntu-linux-12-04/ for instructions on installing the CompizConfig Settings Manager and using it to get Gnome/Metacity to work the way you want.

In particular, once you have it installed, you want to click on "Window Manager", click the "Put" checkbox, then click the word "Put", "Misc Options" tab, and then click the "Avoid Offscreen" checkbox.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.