Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

So I got this new Samsung monitor that came with a CD with manual and drivers. I know that for all new Plug and Play monitors installing the driver(s) is kind of moot. Nevertheless, for the heck of it I want to know how to do it so it won't show Generic PnP Monitor in the Properties.

I can't seem to find where from in Windows 7. Can anyone help?!

PS. Since I'm exporting the signal from a notebook computer I can also revert to the laptop's monitor (if changing the external monitor's driver on-the-fly is not possible).

share|improve this question
there is no setup on the disc to run? In any case, you can run devmgmt.msc from a run prompt to bring up the device manager, you should be able to go to monitors and update drivers there. – MaQleod May 16 '11 at 15:13
The setup simply adds the driver. I can see it's installed in the System tab, just below Generic PnP Monitor. The thing is, apart from that, it chooses the generic monitor and not the dedicated driver. – Kensai May 16 '11 at 15:17
Have you tried uninstalling the device, then adding it again? Might pick up the right driver that way. – MaQleod May 16 '11 at 16:42
Hmm, I did that the first time. I have thought of a reason actually. It might be my case. As I said in my Postscript, I'm using the new monitor to compliment a notebook. Could it be that it won't choose (it's already installed as I said) the new driver because the Generic PnP Monitor fits both the external and the integrated (on the laptop) monitor? – Kensai May 16 '11 at 16:56
up vote 2 down vote accepted

On XP at the moment but you should be able to specify the location of driver you want to use:

  1. Start Menu, right click Computer and select Manage
  2. Select Devices on left and find monitor in list that appears
  3. Right click and select Update Driver
  4. In dialog that appears choose to specify location and select the DVD / installed driver (if on HDD already)

Should auto-update and find the new driver

share|improve this answer
Same in Windows 7 – Tog May 16 '11 at 16:21
The procedure is indeed almost the same. Nevertheless, the problem persists. The driver seems to be already installed but NOT chosen. It still shows in my Monitor Properties that I have a 'Generic PnP Monitor'. – Kensai May 16 '11 at 16:37
Glad to hear, although written from memory so excuse small variations from actual. Not sure why then. Can u uninstall the selected driver so windows doesn't have option? (think under advanced) – James May 16 '11 at 17:06
Thank you for your suggestions. But perhaps I know why it's doing this. Check out the comment in the original question. Since I use one computer and two monitors (the laptop's and this external I'm trying to choose the driver) with the same graphics card, it might choose the common denominator which is a Generic PnP monitor. I'm not duplicating my screens, I use only one at a time, but that might be enough to prevent the system from letting me choose the dedicated driver. Just a guess. – Kensai May 16 '11 at 17:22
Nice. However a small price to pay for the voyage of discovery "for the heck of it"... ;-) – James May 16 '11 at 17:40

Gotta click Have Disk on one of those dialogues to get around the message saying that the generic driver will be used instead of the one you specified.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .