Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a small business network, where there is a centralized imaging machine. This machine then has a shared folder with all the stored images. Originally the imaging machine was an XP, and the shared folder was easily accessed by all. However, we recently had to upgrade that machine to a new one with Win7 installed. The same shared folder is no longer accessible from the XP machines. I'm also assuming that the local firewall isn't causing issue since previously the connection was fine.

The Exact error that I get:

"Network Path not accessible"

Steps that I've taken:

  1. Turned off firewall on both computers
  2. Made sure that 'everone' and specific user connecting has full permission
  3. I can run net view command from command prompt and see the imaging machine
  4. I CANNOT ping the 'imaging.domain.localhost' successfully from the XP
  5. I CAN ping the specific ip address of the imaging machine (win7) from the XP
  6. I CANNOT access the shared folder from another Win7 machine
  7. I CAN connect via ip address: \192.168.1.1

Note: this is joined to a domain

Update:

Although the static ip address and NAT routing table appears to solve the situation, whenever I use the host name (\imaging) vs ip address (\192.168.1.1) the ip address resolves immediately while the 'imaging' takes roughly 30 seconds to 1 min.

Any suggestions?

share|improve this question
    
Is this Win7 Home or Pro? I'm assuming Pro, but I just want to check. –  Doltknuckle May 16 '11 at 20:41
    
@Doltknuckle Win Pro –  KronoS May 16 '11 at 20:42
    
Did you reboot after turning the firewall off? Or did you stop the service? –  Kyle May 16 '11 at 20:54
    
Also since your seem to have an issue resolving the name have you tried connecting to the share via IP? –  Kyle May 16 '11 at 20:57

3 Answers 3

up vote 2 down vote accepted

You can try these steps:

  1. Make sure that the imaging system has a static ip address
  2. Make sure that the NAT routing table correctly resolves the host name to the ip address:
    \imaging --> \ \192.168.1.1
  3. Make sure that public folder sharing is enabled
  4. Make sure that File and Printer Sharing is enabled

Both steps 3 and 4 can be found in Control Panel-->Network and Internet-->Network and Sharing Center-->Advanced sharing settings

share|improve this answer

You should be able to connect to the machine by typing in the UNC path name (\\computername). On most machines, you will get an empty explorer window. If you get that far, try sharing the folder again.

You do this by right clicking on the folder and going to properties. Under the Sharing tab, click the share button and specify who you want to share the file with. This will generally create the NTFS permissions for you. You could also hit the Advanced Sharing button and manually set the share level Permissions.

The only other issue could be some random Group Policy setting that is causing problems. Do you have other Win7 machines that work? This sounds like a weird configuration setting issue.

[EDIT]

If you are unable to connect using a UNC path, then there is something weird going on. Make sure that the DNS name is resolving properly. That could be a domain issue.

Other than that, you should make sure that the network discovery and the like are turned on (step 2 on this page). You might also want to make sure that password protected sharing is off. Make sure that you are setting the correct network type for this. If you go to network and sharing center, make sure that it is not a "public" network.

[END EDIT]

share|improve this answer
    
That's how I already shared the folder, and thus having these issues. –  KronoS May 16 '11 at 21:08
    
can you connect to the UNC path for the computer? Is that area blank or are there folders? –  Doltknuckle May 16 '11 at 21:58
    
No I cannot (well actually I can now, but that's due to my giving it a static IP address) but before then I was not able to connect via the UNC path. See my answer. –  KronoS May 16 '11 at 22:01
2  
I'd try to get that UNC issue resolved, If you can't connect using UNC, it's not a file sharing issue. All systems should at least respond with a blank window when you send a UNC request. –  Doltknuckle May 16 '11 at 22:12
    
Because the system is joined to a domain the 'password protected sharing' is not an option. –  KronoS May 16 '11 at 22:14

Windows 7 and XP networks, in my experience, are not quite compatible. Interaction might work, or it might not. The network might work correctly today, but not work tomorrow.

One major problem is defining the master browser computer for the network. The article Computer Browser contains a good explanation of the problem, and how to assure that the right computer is elected as the master. The problem to avoid is for Windows 7 to come up and decide that it is the master browser of its own network of one, while the XP computers elect one of themselves as master browser of their own little network. Windows 7 should normally provoke in due course a re-election of the master browser for the network, but this can take quite a long time (unless you have a domain).

To make the XP machines discoverable by Windows 7, you should install on them the Link Layer Topology Discovery (LLTD) Responder. Windows 7 should also have the Guest account enabled with the right permissions, since the XP machines might identify themselves as Guest (unless you have taken other steps).

If everything fails, the last resort is giving all the machines fixed IP addresses and updating the hosts files on your network to contain all the addresses.

Check also this article : File and Printer Sharing in Windows Vista.

Other points:

  • Workgroup Name of all the computers should be the same.
  • In Vista Network and Sharing:
    Network Discovery: ON (So it can see the other computers)
    Network set to Private (Public is for hotspots, airports, etc)
    File Sharing: ON
    Public Folder Sharing: ON (Vista Public Folder is the same as XP Shared Docs)
    Password Protected: OFF (unless you want to set up identical usernames and passwords on all computers in your Network). If you have it ON, you will be asked for a username and password when you try to access a Vista computer from an XP computer.
  • Run the XP Home Network File and Printer sharing Wizard.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.