Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently installed XAMPP on my laptop. It installed correctly but the Apache web server won't start - it's a problem with port 80.

It's not caused by Skype, because I don't have it installed. I went through the process of looking for the process ID etc and found it was a system process; when I stopped it the computer crashed.

How do I get the Apache server to work on port 80?

share|improve this question
    
I've been mucking about with XAMPP for a couple months now. I find it very buggy and unpredictable. Apparently the group who was developing it had some issues, people left, a new guy took over, and subsequently released a buggy version (the latest). I've had issues primarily with pathing, specifically, and must run XAMPP-Config every time I want to use it. Bad times. I've been using WAMP at work, at it seems to be quite a bit more stable. Might be worth a try. –  Bosworth99 May 16 '11 at 23:40
    
You have to stop the system process from using port 80 first. IIS? –  Turbo J May 17 '11 at 2:42
add comment

migrated from serverfault.com May 17 '11 at 2:16

This question came from our site for professional system and network administrators.

4 Answers

Thanks guys - it was IIS that was running on port 80. I hadn't even installed it so I assume it came with Windows.

I typed in IIS in the search bar, opened it, then stopped everything and now it's working fine. I think it would have been easier if the process could have been called IIS or something similar as opposed to System which is no help at all. Anyway thanks for solving the problem.

share|improve this answer
    
You can also remove IIS from the system with Add/Remove Features. And also I would personally recommend Uniform Server, probably the best portable web server I have used. –  Sandeep Bansal May 18 '11 at 20:34
    
Well everyone has their opinion on what is best, i am new to this web server stuff. So far i recieved about 3 different answers all stating the one they use is "best". I am only using this one as it was the first one someone recommended to me and now its working fine i dont intend to change it, "if it aint broke dont fix it". –  harry May 19 '11 at 22:17
    
I guess so, but it is a package full of a lot of files that tend not to be used. I was like you where I used Xampp because it worked. But then trying out different Web Servers was a fun idea to see what I liked and Uniform Server really appealed to me since it was very lightweight. Anyway the best webserver is the one you configure on your own. Good luck with development! –  Sandeep Bansal May 19 '11 at 22:25
add comment

There are two ways you can find out more information about the problem...

1) Cross-reference PID to process name.

Open the command line (run cmd.exe) and type in: netstat -aon

C:\Users\admin>netstat -aon

Active Connections

Proto  Local Address          Foreign Address        State           PID
TCP    0.0.0.0:80             0.0.0.0:0              LISTENING       6200
TCP    0.0.0.0:135            0.0.0.0:0              LISTENING       892
TCP    0.0.0.0:443            0.0.0.0:0              LISTENING       6200
TCP    0.0.0.0:445            0.0.0.0:0              LISTENING       4
TCP    0.0.0.0:5357           0.0.0.0:0              LISTENING       4
TCP    0.0.0.0:49152          0.0.0.0:0              LISTENING       564
TCP    0.0.0.0:49153          0.0.0.0:0              LISTENING       1056
TCP    0.0.0.0:49154          0.0.0.0:0              LISTENING       1108
TCP    0.0.0.0:49155          0.0.0.0:0              LISTENING       620
TCP    0.0.0.0:49156          0.0.0.0:0              LISTENING       608
TCP    127.0.0.1:5354         0.0.0.0:0              LISTENING       1444
TCP    127.0.0.1:27005        0.0.0.0:0              LISTENING       2200
TCP    192.168.1.100:139      0.0.0.0:0              LISTENING       4

Locate the first line with Local Address of 127.0.0.1:80 or 0.0.0.0:80

Then use Task Manager (ctrl-alt-del) > Processes Tab (show all) to find out which Process has this PID.

2) Check the Apache's error log file or start Apache from the command line and check the error message:

httpd -k start

The IIS Service is called W3svc and you can stop it and also disable it (disables the automatic start-up) via Services window (run servers.msc).

You should also try using WampDeveloper Pro which has a much better setup process that detects and handles other software running on port 80.

share|improve this answer
    
If you add a -b to netstat, it'll show the executable associated with the connection, so netstat will directly tell you what application is holding open the port. There's no need for the second step of using Task Manager. –  Chris Thompson Jan 1 '12 at 8:45
add comment

If you have TeamViewer installed then you must disable use of ports 80 & 443 in TeamViewer. This can be done by going to Extra->Options->Advanced->Advanced Network Settings.

nkansara

share|improve this answer
add comment

please check your system if you have skype on your system then first close the skype as well as close the process of skype. steps to follow c:/>netstat - ano [it will display all the process] after than c:/>tasklist [it will show the task with process id] c:/>taskkill /PID 2480/F [Here 2480 is process id]

and also check if the iis server is running, if it is running the stop the iis server.

thanking you

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.