Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

On my host machine, I can navigate to grooveshark.com and play music. In my VMWare VM I can't get the grooveshark.com home page to load. Firefox displays a "too long to respond" message and IE gives the "cannot display page" message. Grooveshark worked in the VM at one time, but it stopped a while back. How do I get grooveshark to work in the VM?

share|improve this question

3 Answers 3

Can you get to any website?

I would recommend looking in network settings and trying to make sure it is both connected and set to either bridged or NAT.

share|improve this answer
    
It's bridged. Grooveshark is the only web site I've found that I can't get to. Every other program or web site that uses internet access works. –  John Mo May 17 '11 at 13:47

You maybe have a problem with the Flash version that is installed in the VM, or Flash settings, or cookies.

From The new Grooveshark has display problems!

If you're having a problem with Grooveshark's display (saved music not loading, themes not appearing, white screen, blank screen, side bar), follow these steps and see if they resolve your problem.

  1. Make sure that you have the latest version of Flash installed (http://get.adobe.com/flashplayer).
  2. Test grooveshark.com in another web browser.
  3. In your web browser, try Tools -> Options -> Privacy and then check Accept Cookies from sites.
  4. Turn off any Flashblock extensions.
  5. Restore your browser's normal zoom level.

You should also verify Flash settings on the Online Settings Manager and also on the Local Settings Manager, by comparing them between the physical and virtual machines. Here is how to access the local settings :

To access the local Flash Player Settings Manager that is native to your operating system:

  • Windows: click Start > Settings > Control Panel > Flash Player
  • Macintosh: System Preferences (under Other) click Flash Player
  • Linux Gnome: System > Preferences > Adobe Flash Player
  • Linux KDE: System Settings > Adobe Flash Player
share|improve this answer
    
It's not a display problem. I'm not getting a response at all. My Flash version is the most recent listed. –  John Mo May 20 '11 at 12:15
    
I didn't think it is a version problem, but it may be useful to verify the other points. –  harrymc May 20 '11 at 15:11

I'd comment, but not enough reputation yet. I think more info is needed here...

  • Check the status of VMWare Tools. Are they running in your guest?
  • Are you able to access any other websites? [you answered yes in a comment]
  • Can you post a tracert to the following hosts:

    grooveshark.com
    www.grooveshark.com
    static.a.gs-cdn.net
    

static.a.gs-cdn.net is the Canadian Grooveshark content provider. For some reason I'm not able to access the American one right now, so you'll need to check which host you hit (or are trying to hit).

share|improve this answer
    
Interesting. All ping and tracert commands time out in my host, my VM, and other machines on my network. Must be a setting in my router. Any thoughts on why that would cause a problem in my VM but not anywhere else on my network? –  John Mo May 19 '11 at 21:21
    
That's...weird. I was just thinking the basic networking stuff, like an entry in the host file, a crazy route, a software firewall/antivirus that's intercepting all the traffic. Nothing loads on the page, right? You could try HttpFox or a similar plugin to see if it's able to partially load the page and is blocking on one particular element. –  Code Bling May 19 '11 at 21:47
    
HttpFox is a nice find. Thanks for that. What it tells me is that there's no response. There's a GET, no bytes received, and an error: NS_ERROR_NET_TIMEOUT. The elapsed time is just over 21 seconds, which seems like an odd timeout span. I tried navigating to static.a.gs-cdn.net and it failed, but waited over 60 seconds before returning with a timeout. –  John Mo May 20 '11 at 12:30
    
I've honestly never heard of a LAN setup where ping and traceroute don't work. It might be worth looking into. To get around this, for now, some linux versions of traceroute have a -T -U options. -T Use TCP SYN for probes. -U Use UDP datagrams for probes. If those don't work I'd be very worried. (Maybe you have cygwin in your VM or maybe you have the same problem on your Ubuntu VM and this will help) –  Code Bling May 20 '11 at 14:48
    
The VM is Win 7. It seems to be related to the VM environment itself. I tried from a Win XP VM and Grooveshark is the only site I can't navigate to in that VM. –  John Mo May 20 '11 at 15:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.