Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to setup an Android build environment for Android. I'm following these instructions.

However, after the installation of MacPorts I'm not able to install the environment.

Following the instructions I launched this command:

sudo port install gmake libsdl git-core gnupg

and I received this message:

Warning: No index(es) found! Have you synced your source indexes?
Error: Port gmake not found

Now, I tried the selfupdate command but the connection timed-out. I tried the different solutions that I found in the MacPort FAQ but I'm not able to connect to SVN. The connection works fine, if I ping a website from the terminal there is no problem.

share|improve this question
It's not self update - it's selfupdate - try sudo port -d selfupdate - focus on getting this step to work – Paul R May 17 '11 at 8:38
thanks a lot, I tried but I have this error: rsync: failed to connect to Operation timed out (60) rsync error: error in socket IO (code 10) at /SourceCache/rsync/rsync-40/rsync/clientserver.c(105) [receiver=2.6.9] – benza May 17 '11 at 8:46
It seems that there is no connection but if I ping other pages works fine – benza May 17 '11 at 8:48
It sounds like maybe you have an old version of macports - try getting the latest version from and start again – Paul R May 17 '11 at 9:00
I checked my version and is the latest one. I installed it using MacPorts-1-2.9.2.pkg and I don't understand why the rsync fails to connect to – benza May 17 '11 at 9:07

Perhaps this is a firewall issue? If you have a proxy server, you might try setting up rsync to work with it. For example:

sudo -E port selfupdate

The -E option preserves the user environment of the sudo-ing user.

Hope this helps -- it worked for me, anyway.

share|improve this answer

Try sudo port -d sync.

It uses svn whereas selfupdate uses rsync. I got it from this thread:

share|improve this answer

If you're behind a firewall, you'll need to open port 873 for rsync.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .