Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to setup an Android build environment for Android. I'm following these instructions.

However, after the installation of MacPorts I'm not able to install the environment.

Following the instructions I launched this command:

sudo port install gmake libsdl git-core gnupg

and I received this message:

Warning: No index(es) found! Have you synced your source indexes?
Error: Port gmake not found

Now, I tried the selfupdate command but the connection timed-out. I tried the different solutions that I found in the MacPort FAQ but I'm not able to connect to SVN. The connection works fine, if I ping a website from the terminal there is no problem.

share|improve this question
    
It's not self update - it's selfupdate - try sudo port -d selfupdate - focus on getting this step to work –  Paul R May 17 '11 at 8:38
    
thanks a lot, I tried but I have this error: rsync: failed to connect to rsync.macports.org: Operation timed out (60) rsync error: error in socket IO (code 10) at /SourceCache/rsync/rsync-40/rsync/clientserver.c(105) [receiver=2.6.9] –  benza May 17 '11 at 8:46
    
It seems that there is no connection but if I ping other pages works fine –  benza May 17 '11 at 8:48
    
It sounds like maybe you have an old version of macports - try getting the latest version from macports.org and start again –  Paul R May 17 '11 at 9:00
    
I checked my version and is the latest one. I installed it using MacPorts-1-2.9.2.pkg and I don't understand why the rsync fails to connect to rysing.macports.org –  benza May 17 '11 at 9:07

3 Answers 3

Try sudo port -d sync.

It uses svn whereas selfupdate uses rsync. I got it from this thread: http://lists.macosforge.org/pipermail/macports-users/2007-July/004725.html

share|improve this answer

Perhaps this is a firewall issue? If you have a proxy server, you might try setting up rsync to work with it. For example:

export RSYNC_PROXY=myproxy.domain.com:80
sudo -E port selfupdate

The -E option preserves the user environment of the sudo-ing user.

Hope this helps -- it worked for me, anyway.

share|improve this answer

If you're behind a firewall, you'll need to open port 873 for rsync.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.