Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a network drive mapped to a share on a Window Server 2003. I have a shortcut to this drive stored in my Windows 7 favorites. When I double click the shortcut and then rename a file on the drive, if the file is longer than 8 chars or contains spaces then I get this error

The drive that this file or folder is stored on does not allow long file names, or names containing blanks or any of the following characters:...

If I get to the network drive by click on it in the tree under computer then it works fine. Is there a way to get round this?

(Update: sometimes the drive isn't available in the tree, even though it's mapped. I have to kill the explorer.exe process and restart it to make it appear in the tree.)

share|improve this question
    
I also have this problem and get this error message. Specifically I CAN create/rename files in folders that I access via their Network path (eg \\Server\Share\Folder\File.doc) but I can NOT create/rename the same files in the same folders that I access via their Computer path (ie mapped network drive) (eg N:\Folder\Myfile.doc). I am running Windows 7, and the network storage device is a NAS (unix based). I happen to have Windows Synchronisation/Offline Folders enabled on this device. – user153998 Aug 23 '12 at 3:28

I read somewhere that explorer hasn't finished loading properly. Quickest fix seems to be; use task manager to end the explorer process then; use New Task to start it up again.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .