Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I recently installed a lot of updates for Ubuntu 10.10, since 11.04 didn't work on my system (Lenovo x201).

Today after the update, grub still exists and lists all OS on boot-up. Starting Windows 7 is no problem but starting Ubuntu just does not work. When starting Ubuntu the system comes to the loading screen, but it shows no HDD activity (no HDD-activity light). It just stays that way.

I really need to get the system running ASAP.

I already tried this HowTo but it didnt worked.


fdisk -l

Disk identifier: 0x8bd47c21

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1       21624   173688832    7  HPFS/NTFS
Partition 1 does not end on cylinder boundary.
/dev/sda2   *       30739       38914    65659904    7  HPFS/NTFS
Partition 2 does not end on cylinder boundary.
/dev/sda3           21624       30739    73219073    5  Extended
/dev/sda5           21624       30134    68358144   83  Linux
/dev/sda6           30134       30739     4859904   82  Linux swap / Solaris

Partition table entries are not in disk order

Disk /dev/sdb: 32.1 GB, 32128368640 bytes
14 heads, 11 sectors/track, 407472 cylinders
Units = cylinders of 154 * 512 = 78848 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x000d4beb

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *          54      407473    31371264    c  W95 FAT32 (LBA)
share|improve this question
    
I guess one of the updates crashed your system. Do you have an old recovery left to boot? – Michael K May 17 '11 at 15:04
    
unfotunatly now :( – buffkit May 17 '11 at 15:07
    
Can you get into the grub menu and select an older kernel? – pberlijn May 17 '11 at 15:40
    
yes, even booting Win7 is possible. If i try to boot Ubuntu 10.10 (any kernel version) the loading animation runs but nothing is loaded ... – buffkit May 17 '11 at 15:43
    
What does recovery mode tell you? – pberlijn May 17 '11 at 15:46

there was a bug in ubuntu, where after an update, the UUIDs of the hard-drive partitions have changed. Try to tell grub to boot from /dev/sda5 - instead of the UUID that it is probably trying to.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .