Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Since updating to Firefox 4 I've had a problem:

With Firefox 3.x I could start it without a Internet connection and almost all of my open tabs were still loaded. With this I was able to read my open sites in the train where I have no Internet connection.

However this does not work in Firefox 4; if I launch Firefox 4 I see all my open tabs but the content is not available. It seems that the new version tries to refresh all tabs on startup.

Is it possible to disable this behaviour?

share|improve this question
    
I do really miss that feature :-) –  MadBoy Jun 15 '11 at 18:18
    
Maxim are u using normal version of Firefox or Portable one? –  MadBoy Jun 16 '11 at 9:26
    
At the time I wrote the question I used the standard Firefox version which was shiped with Ubuntu 11.04. Now I updated to Firefox 5. The problem still exists –  Maxim Aug 9 '11 at 19:12
    
after I switched Options -> Advanced -> Network -> Uncheck Override Automatic Cache Management to Automatic from 0 it started to work. i use portable version of Firefox 7 for Windows –  MadBoy Aug 15 '11 at 18:50
add comment

3 Answers 3

This might work for you : start the Firefox profile manager as follows :

firefox.exe -ProfileManager  (Windows)
firefox -profilemanager      (Linux)

then "Start Firefox" for your profile after ticking "Work offine" :

image

share|improve this answer
    
Are you proposing that every time I start firefox I should use this? –  MadBoy Jun 21 '11 at 18:24
    
Try once and see if the setting "sticks". If it doesn't stick, then the answer is yes. If it does stick, then on the other hand you will have to undo it to connect back. –  harrymc Jun 21 '11 at 19:27
    
Well this isn't what I want/need. In firefox 3.6 i could leave my tabs open and get back to it even without internet connection. It was just not refreshing things on start. Right now it does. I am not sure whether it's normal behaviour for 4+ or maybe it changed for portableapps firefox. Doing this thru profiles seems like an overkill. –  MadBoy Jun 21 '11 at 19:36
    
You could use this method as a stopgap solution, while presenting the problem to the Firefox developers at Bugzilla. –  harrymc Jun 22 '11 at 6:07
    
Are you seeing this problem too? I want to confirm that others in new versions have the same behaviour as I do. I use Portable version of Firefox 6 (aurora right now) but I've been using Portable version since 2.0 and till new 4.0 version it was working as explained by maxim. –  MadBoy Jun 22 '11 at 8:23
show 4 more comments

Make sure your offline cache is enabled, it should be set to true by default. In your address bar type:

about:config

In the filter field type:

browser.cache.offline.enable

Make sure this value is set to true (can be toggled by clicking on it).
You can do the same for "browser.cache.offline.capacity" which has a default value of 512000

share|improve this answer
    
This does not solve my problem. The offline cache is enabled and the cache size is 512000. The problem must be somewhere else. –  Maxim May 24 '11 at 19:04
    
OK, try this one, I'm not sure if it functions how you want it to:- back into about:config, find network.manage-offline-status and set to true –  Tog May 25 '11 at 20:50
    
I tested this setting but it still not works as I was used to it. –  Maxim Jun 8 '11 at 20:10
add comment

I've had the problem myself but it seems that it started working again when I did:

Options -> Advanced -> Network -> Uncheck Override Automatic Cache Management. Before that it was Checked with 0.

Please try it Maxim and let me know if it helps. Maybe it was some add-on I've installed recently (Tab Mix Plus comes to my mind - I wasn't using it for longer while after it was incompatible with 4.0 but now it is and installed it again). So it's either that setting or some this add-on (or both).

share|improve this answer
    
On my system I can not identify any difference when I switch this setting on or off. –  Maxim Aug 9 '11 at 19:25
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.