Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've been playing aroung with a Ubuntu Server 10.04 installed through VMware (the host is Windows XP). For any reason (I suspect a power off of my host machine), the guest OS seems broken.

Every time I boot the virtual machine, I get stuck at an initramfs prompt, after what seems like a kernel panic trace and the following lines:

mount: mounting /dev on /root/dev failed: No such file or directory
mount: mounting /sys on /root/sys failed: No such file or directory
mount: mounting /proc on /root/proc failed: No such file or directory
Target filesystem doesn't have /sbin/init.
No init found. Try passing init= bootarg.

Busybox seems to allow entering commands, then the (initramfs) prompt is shown.

I booted with a Ubuntu Live CD and tried:

  1. Checking entries in /dev : I can see /dev/sda, /dev/sda1, /dev/sda2, /dev/sda5
  2. Mounting /dev/sda1, but the mount command doesn't return (I waited for 10 seconds, I assume that's sufficient?)
  3. fsck -c /dev/sda1 - but fsck reports that /dev/sda1 is busy.
  4. Checking dmesg when using the Live CD:

    EXT4-fs (sda1): INFO: recovery required in readonly filesystem
    EXT4-fs (sda1): write access will be enabled during recovery
    EXT4-fs warning (device sda1): ext4 clear journal err: Filesystem error recorded from previous mount: IO failure
    EXT4-fs warning (device sda1): ext4_clear_journal_err: Marking fs in need of filesystem check.
    

What could I try next? The machine contains valuable source code so I'm hoping I can find a solution!

share|improve this question
add comment

2 Answers 2

up vote 2 down vote accepted

Try

$ fsck -y /dev/sda1

From the LiveCD

share|improve this answer
    
Hi Simon, tried a "last chance" Googling based on "IO failure" message from dmesg output. I found this :bugs.launchpad.net/ubuntu/+source/udev/+bug/668561. So I used Slax to submit the fsck (basically, the Ubuntu Live CD automagically mount /dev/sda1, so it seems not to be possible to fsck it. Maybe with the -y flag, but your answer was too quick, sorry!). Thank you ! –  SCO May 17 '11 at 20:51
    
Okay, Hopefully you get things worked out though! –  Simon Sheehan May 17 '11 at 21:50
add comment

The live CD mounts the /dev/sda1 partition automatically. All you have to do is first run:

umount /dev/sda1

Then run:

fsck -y /dev/sda1

That did it for me.

share|improve this answer
add comment

protected by Community Feb 3 '12 at 11:57

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.