Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have two 2560x1440 monitors running off an ATI Radeon 6970 on Windows 7.

Before reformatting, I had adjusted the DPI to 120 via Control Panel > Appearance and Personalization > Display > "Medium - 125%". I am not entirely sure, but I think I had checked "Use Windows XP style DPI scaling" (which is the default for DPI less than 144 I believe). My apps looked fine; the text size was larger, but it never really caused any problems.

However, upon reformatting, I tried to do the same thing and have ended up with messed up text and icons in my apps. Examples:

Outlook icons are resized improperly

In Outlook, the icons are resized in crazy ways and look much worse, and the text---except for the actual message list---is oversized.

muTorrent text overlaps

In muTorrent, the text is too large to fit in its bounding boxes, and gets clipped.

I have tried right-clicking on the program and choosing Properties > Compatibility > Disable display scaling on high DPI settings; this does nothing.

Also of note: in Windows Explorer, things look fine; the text is not comically oversized and the icons are not scaled up.

Any ideas?

share|improve this question

1 Answer 1

up vote 3 down vote accepted

Of course I solve this minutes after posting it, despite a couple days of banging my head against the wall X_x.

If I switch to Windows Classic theme under Control Panel > Appearance and Personalization > Personalization, then back to Windows 7 (Aero) theme, the fonts get resized back to reasonable and the icons stop getting scaled weirdly.

So, somehow my font size and/or DPI scaling got tied to my theme. I believe this occured because I experimented with 144 DPI (150%) for a few minutes, during which time I might have mucked around with theme settings, perhaps switching from Basic (the default) to Aero.

share|improve this answer
1  
You should mark your question as answered –  Tog May 18 '11 at 6:45
2  
@Tog That only works in two days –  slhck May 18 '11 at 7:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.