Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using a Macbook Pro, 2 years old. 8GB RAM, generally hard working machine. If I restart it once a month it's a lot.

Since this morning it began locking up intermittently - whichever application I was in would stop responding for around 5 to 20 seconds (up to 30 seconds at time). All I get in the app is the spinning color wheel. I still (usually) have the ability to tab around and take a look at activity monitor, but the app I was in won't respond. The lockups happen in all apps, not just the browser window.

I killed all the usual suspects in an effort to track down the offending app or process, and have had no success.

A couple of restarts later, I have removed almost everything that runs in the background and it's still happening. I initially thought it was chrome, but it happens with safari as well.

There is nothing unusual in the console or system log, and the only visible change is if activity monitor is open, it shows a large spike in IO/sec immediately after the system unlocks. Running top on the command line reveals nothing unusual. Nothing has been installed on the machine in the last few days.

any ideas what I can use to track down the offending process or activity?

share|improve this question
    
I had something similar for a while. I believe it is related to the hard disk. Does it happen primarily when you access the hard disk? Can you cause other applications to freeze during that time by e.g. opening an Open/Save file dialog? –  Daniel Beck May 18 '11 at 16:10
    
not really - it happens seemingly randomly. Could be when right clicking a link, scrolling down a page - for example, it locked up about 4 times when tying out the question above, but was fine while typing this comment. –  random_task May 18 '11 at 16:14
    
Daniel, you were right - see update below –  random_task May 19 '11 at 6:44
add comment

1 Answer

up vote 1 down vote accepted

The symptoms you've described are often caused by failing hard drives. Look in your system.log and kernel.log (you can get /Applications/Utilities/Console to let you select these logs instead of the console log if you click on the "Show Log List" icon button) for messages approximately like "disk0s2 I/O Error: UNDEFINED". These are indications that your system is having a hard time reading one or more blocks from your hard drive. When this happens, all disk I/O gets blocked while the disk does a "slow read" trying to see if it can successfully scavenge the data from the dying block.

Modern drives lock out bad blocks automatically, but only on write. If you're seeing those error messages in your logs, you may be able to resuscitate the drive somewhat by forcing every block to be written to:

  1. Back up any important data you can still get off the drive if you don't already have a good backup.
  2. Check your backup to make sure it's correct and it works.
  3. Erase your hard drive with the "Zero Out Data" option to make sure every block gets written to. A normal erase won't do.
  4. Restore from your backup.

Note that hard drives with one or two bad blocks will usually still show "SMART Status: Verified" in Disk Utility; you usually won't see a drive report a SMART failure until all of its spare blocks have been depleted. Mass storage engineers with much more knowledge than me tell me that once a hard drive starts showing bad blocks, that the problem is about to snowball, ending with a dead drive. I will say, though, that I've apparently lucked out, because I've resuscitated several drives as described and had them continue to work well for years, until I replaced the machine. I'd still be super wary and make sure I have a good backup strategy.

share|improve this answer
    
There aren't specific disk IO errors, but this definitely seems to be drive related. A disk utility verify picked up errors in the catalog, and a repair seems to have worked. –  random_task May 19 '11 at 6:43
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.