Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

At the end of each workday, I shut down my computer.

My instinct is to hit , , , , switch off the monitors and walk away.

However, Skype will prevent system shutdown by asking:

Skype pestering

Of course, with all monitors switched off already, I will not notice this until the next morning and it is driving me nuts.

Do you know how to make Skype just shut down (and up) when I tell it to shut down?

Edit: I am using Skype 5.1.0.935. To reproduce, open Skype, open some conversation (double-click some contact), then quit Skype using the Dock icon or , Q.

share|improve this question
    
Cannot reproduce. What version of Skype are you using? –  Daniel Beck May 19 '11 at 8:04
    
@Daniel open a chat or a call or something, then you will be able to reproduce it. –  bastibe May 19 '11 at 11:22
    
Can't reproduce it either. Using 5.1.0.935. –  slhck May 19 '11 at 13:03
    
That is totally weird. I am using 5.1.0.935, too –  bastibe May 20 '11 at 6:17
    
Still cannot reproduce. Still using 5.0.0 though. Are you using non-standard (paid) Skype services that might be the cause for this? –  Daniel Beck May 20 '11 at 6:28
show 3 more comments

4 Answers

up vote 3 down vote accepted

I know it isn't much of a solution, but have you tried deleting the Skype app bundle, and deleting ~/Library/Application Support/Skype? It could be there there is a legacy config option in the config.xml that isn't in the UI anymore?

The config.xml is in ~/Library/Application Support/Skype/

share|improve this answer
1  
This is as if a doctor would say "I can't fix this patient, so lets kill him and get a new one that works". But work it does. –  bastibe Jun 22 '11 at 12:11
1  
Well yes and no. I started from the assumption that there was a legacy config option that was no longer present in the UI. You could have gone through all of the config files in there, so I did sort of use a circular saw when a hand saw would have worked I suppose. In any case, glad that it helped! –  Kirk Jun 22 '11 at 12:58
1  
@Paper this is more like "We could perform hours of delicate microsurgery to repair this patient's mangled fingers, but he's Hitler, so we'll just take off the hand and be done with it." –  jozzas Sep 27 '11 at 5:28
add comment

Our numerous customers called us with the same problem. Skype for Mac does not have a setting to turn off the log-off confirmation. I tried latest Skype as of today, version 5.3.0.1093, on our development Mac and Skype has the same problem there - it prevents Mac from shutting down.

By the way, the latest Skype for Windows has a similar problem on Windows XP, Vista and Windows 7. It cannot prevent Windows from shutting down, but it hangs and Windows has to force close it when shutting down.

One way of dealing with it is to turn off ALL notifications if you'd rather live without any of them than having this annoyance with Skype preventing you from shutting down your Mac without user's intervention:

Start Skype, then go to the file menu Skype, then Preferences, then Notification and check the "Disable all visual notifications" checkbox.

share|improve this answer
add comment

If you have a file transfer that hung in Skype, it'll keep giving you that warning dialogue when you try to quit.

I'm running an older version of Skype but the location of the transfers window should be:
Skype >> Window >> Transfer

Look through your file transfer history and cancel any that are hung. That should take care of it.

share|improve this answer
add comment

After using Skype, right-click on the Skype logo in the dock and click on quit skype.

share|improve this answer
1  
Right, but that does not solve me shutting down the system and walking away. The point is that I don't want to explicitly quit Skype. It should just quit when the OS is shutting down. –  bastibe Dec 18 '11 at 17:43
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.