Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've got a mtu problem. I did the following:

root@sa-headend:/home/sa# ifconfig lo mtu 1500
root@sa-headend:/home/sa# ifconfig lo
lo        Link encap:Lokale Schleife  
          inet Adresse:127.0.0.1  Maske:255.0.0.0
          inet6-Adresse: ::1/128 Gültigkeitsbereich:Maschine
          UP LOOPBACK RUNNING  MTU:1500  Metrik:1
          RX packets:143 errors:0 dropped:0 overruns:0 frame:0
          TX packets:143 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenlänge:0 
          RX bytes:58028 (58.0 KB)  TX bytes:58028 (58.0 KB)

root@sa-headend:/home/sa# ip route flush cache

How is it possible that I get packets like this one: (Using Wireshark to capture)

15  0.028587    127.0.0.1   127.0.0.1   TCP 10005 > 49152 [ACK]
    Seq=4717 Ack=53 Win=14600 Len=1608

The TCP packets are generated by a Java socket - if thats of any relevance.

Please don't ask why I want to change the MTU on lo - I just have to do this.

share|improve this question

1 Answer 1

up vote 3 down vote accepted

Sorry to be the guy that mistakenly assumes all Unix-like OSes are alike, but is there any chance your kernel thinks your loopback interface supports TCP Segmentation Offload (TSO)?

In Mac OS X (think "BSD"), if you do a packet capture on the same machine that's sending the packets, you can see impossibly large TCP frames being sent down to the card, because the stack knows that the card will do TSO to chop it up into 1500-byte chunks. On Mac OS X you can disable it with sudo sysctl -w net.inet.tcp.tso=0.

On Linux, for an Ethernet interface, it looks like you can do sudo ethtool -K eth0 tso off. I don't know if that would work on the loopback interface (instead of ethX) though.

share|improve this answer
    
A million thanks! ethtool -K lo tso off does in fact work on my ubuntu and did solve the problem. I need this for my student research project and we have been trying to pinpoint this error for quite a while now.Maybe I can publish my work when I'm done. –  Simon Ottenhaus May 22 '11 at 13:53
    
Don't know yet if this is the problem that we are experiencing, but it is a darn subtle one, and a good one to know about. Dang. –  Mihai Danila Sep 13 '13 at 16:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.