Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Using Win7-64 Ultimate RTM and IE 8, opening an URL with wma or wmv does not work.

Opening the same file in FireFox or Opera is no problem, they use Windows Media Player just fine.

The file associations for both file types are set to Windows Media Player so it must be another issue.

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

Try this (found on Social answers @ Microsoft) by Charles Fook

Fix:

Open notepad paste these lines in

Windows Registry Editor Version 5.00
[HKEY_CLASSES_ROOT\.avi]
@="WMP11.AssocFile.AVI"
[HKEY_CLASSES_ROOT\.asf]
@="WMP11.AssocFile.ASF"
[HKEY_CLASSES_ROOT\.wmv]
@="WMP11.AssocFile.WMV"
  • Save file to your desktop 'filename'.reg -- make sure you change it from saving as a .txt file to a "." file
  • Open the file and agree to adjust registry
  • Open your movies
share|improve this answer
    
This works, I found a solution to this and fixed it a week ago, but had forgotten the what registry values to change. The question then is why is it like this in a new install of Win 7 / IE 8 with no extra codecs or other media players. –  vzczc Aug 24 '09 at 13:21
    
It might be cleared as a default, since IE 8 doesn't have to be your default browser –  Ivo Flipse Aug 24 '09 at 15:39
    
It is my default browser –  vzczc Aug 25 '09 at 10:02
    
Just because it is, doesn't mean Windows automatically sets it as being so ;-) –  Ivo Flipse Aug 25 '09 at 10:34
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.