Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I use Linux as my primary desktop, my path is on this workstation is /home/matt, I have a good few places and configs that I sync between Linux and my Mac via Dropbox, on my mac my home path is /Users/matt. e.g. local bookmarks are sync via Firefox Weave (like XMarks) such as file://home/matt/My Dropbox/offlinepages/jquery-help.html

I'm trying to symlink /home/matt to /Users/Matt on my mac so everything aligns equally, but I get Operation not permitted even under a sudo bash.

share|improve this question
    
My reading of your question is that your Mac is a different machine to your Linux box. Is this right? –  Lukasa May 20 '11 at 17:22
2  
It actually says: Operation not supported. I was unable to do it this way without reboot, but it might work for you. –  Daniel Beck May 20 '11 at 18:01
1  
@Lukasa. Wouldnt really be a question would it? Should the last character of your username be 's' not 'a'? I think so. Thanks Daniel for the link. sudo ln -s /Users/Matt /home/matt worked perfect after removing that line from auto_master. –  mattcodes May 20 '11 at 18:45
    
You never know. Imagine how silly I'd look if I assumed you meant a local machine and not a remote one, or vice versa. And no, it's just Lukasa. It's totally unrelated to my RL name. –  Lukasa May 20 '11 at 21:24
add comment

1 Answer

You need to disable automount. Use sudo edit /etc/auto_master to comment out the /home line. My auto_master file looks like:

#
# Automounter master map
#

+auto_master            # Use directory service
/net                    -hosts          -nobrowse,hidefromfinder,nosuid
# /home                 auto_home       -nobrowse,hidefromfinder
/Network/Servers        -fstab
/-                      -static

Then run sudo automount -v -c.

You should see the output:

automount: /net updated
automount: /home unmounted
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.