Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

There have been various reports of DD-WRT QoS not working (here, here and elsewhere).

The DD-WRT QoS Documentation mentions some checks would indicate whether the proper priorities are being applied to the traffic. (Though it does not suggest a method to verify that QoS is actually taking effect...)

Has anyone checked their traffic priorities and found that the priorities are not being correctly applied, or that they have been properly applied but that did not seem to change anything? (Or, having enabled QoS, see traffic degradation or other issues.) Bonus points if you've actually quantitatively tested your QoS setup.

Just to clarify, I'd like to know if setting up QoS using the GUI works. (I'm using OpenWRT right now and I can just as easily use a script there. What interests me is if I can waste less time setting QoS up by switching to DD-WRT)

Answers I'm NOT looking for:

  • "Just switch to Tomato/OpenWRT/X-WRT/Gargoyle/etc"
  • "OF COURSE it works, why wouldn't it?"
  • "Just use this script" (or some other script)
  • "QoS only affects outgoing traffic and doesn't really help anyways"

UPDATE 2011-06-02: There weren't any answers from actual DD-WRT users, but the prevalent opinion seems to be that QoS in DD-WRT (when configured via the GUI) is broken.

UPDATE 2011-11-29: There's now a LuCi module for QoS on OpenWRT (not sure how long it's been around). I've done some cursory tinkering, if I notice any great wins/fails or can devise a test scheme, I'll try it out and report back.

UPDATE 2012-01-31: Gui Ambros has submitted the best answer so far, and although many people still complain that QoS doesn't work, I also feel that QoS is a difficult beast to tame, so I'm always suspicious that it was not correctly configured if no testing was done. Accepting his answer. If anyone using a current version of DD-WRT can show that QoS isn't working, please submit a new answer!

share|improve this question
    
What exactly you are trying to accomplish with QoS and how you are measuring its success may make a difference. QoS is a very in depth discussion depending on how it is being used. –  MaQleod May 21 '11 at 3:05
    
Fair enough, but if nobody has ever had any success using the graphical QoS then it's unlikely that I will either and thus I won't embark on that adventure. I'm hoping I'll get several answers with people reporting at least varying degrees of success. –  Code Bling May 21 '11 at 15:09
    
@Code: Very many people complain about QoS not working in DD-WRT, and they switch to Tomato (if they have a router with a Broadcom chipset). I am surprised that the DD-WRT people have not sorted it out after all this time, apparently. –  paradroid May 23 '11 at 11:28
4  
A lot of people complain about things not working when in reality it's that they don't know what they're doing. This may not be te case here but it's also a possibility. –  KronoS May 31 '11 at 13:13
1  
@BlueRaja without supplying any details, it's hard for any one reading this to judge if you have a valid point or if you simply messed up your QoS config/don't know what you're talking about. What QoS rules are you applying? How does enabling QoS affect your latency? What routers are you using? Have you tried using iperf to measure the success of your QoS rules? –  Code Bling May 29 '12 at 17:35

6 Answers 6

up vote 5 down vote accepted

The answers on this question are really outdated. Development on the DD-WRT has moved on and QoS through GUI is super stable on latest versions.

I'm currently using DD-WRT v24-sp2 (09/09/11) big, SVN revision 17598M NEWD-2 K2.6 Eko on an ASUS RT-N16, and deployed complete QoS for my local home network without any issues. Even though I'm very familiar with CLI, the Web interface did just fine. Premium/Express/Bulk traffic now is being properly categorized and I have finally solved my issues with VOIP and video streaming when someone starts a download or bittorrent and takes the whole channel.

To test if traffic was being categorized properly I used iperf and checked connections on /proc/net/ip_conntrack while live testing each combination of app and protocol.

Suggest you take a look again; you might be pleasantly surprised. Just make sure you use a recent build. The DD-WRT Wiki has setup instructions.

share|improve this answer
1  
Thanks !! Can you explain some of the issues you had with streaming and torrents, and how you fixed them? I haven't been using VOIP lately but that's exactly the scenario I was worried about when I originally asked this question. –  Code Bling Jan 31 '12 at 22:59
    
This is definitely not true, see my comment above - the issue is not that traffic is being miscategorized, it's that the QoS scheduler runs so slow that, on normal home routers, it causes an ENORMOUS latency increase for all packets, completely defeating the purpose of having QoS in the first place. QoS on Tomato runs fine on those same routers, though, so it is definitely DD-WRT. –  BlueRaja May 27 '12 at 9:49
    
@BlueRaja maybe your router's CPU isn't powerful enough. You say it worked fine on Tomato, but Tomato also isn't running as many services. Why don't you detail your setup and experience in an answer? I'm sure people will update it -- I know I will, provided it adds useful information to the discussion. –  Code Bling May 29 '12 at 17:41
    
Did someone downvote because they don't like DD-WRT? That isn't what the downvote is for and this isn't meant to be a fanboy battle. –  Code Bling May 29 '12 at 17:43
    
I downvoted because, as I said in my previous comment, "this is definitely not true." –  BlueRaja May 29 '12 at 21:26

I do not use DD-WRT, but it seems that getting QoS to work requires some fiddling.

I suggest to read carefully this post : dd-wrt router firmware QoS troubleshooting from October 2010 (although it only shapes outgoing traffic), where the accepted answer describes a recent QoS script that apparently worked for both answerer and poster.

However, the described method sounds quite painful, with workarounds for for DD-WRT bugs, patches and whatever, and even so only applies to outgoing traffic.

So the answer for your question is : QoS under DD-WRT still needs fiddling for it to work. The GUI by itself is not enough, which was at least the case toward the end of 2010. So in your shoes I wouldn't bother moving to DD-WRT. Or at least not because of QoS, because it seems to me that QoS is potentially quite frustrating and an excellent time-waster.

The article What is DD-WRT? (section "Special Versions") says for the paid version :

Currently brainslayer offers a special version of DD-WRT with extended QoS capabilities:

  • set maximum bandwidth available per netmask/MAC address (v.24-SP1: even for different vlans)
  • set a default rule for any unconfigured netmask/MAC address

So it seems that only the paid version of DD-WRT easily supports QoS.

The article How to limit Up/Down speeds per user w/o paid version describes a tool that "works just great for the purpose of setting upload/download limits for users based on IP or MAC addresses".

share|improve this answer
4  
waiiiiit a minute. Did you take one of the links I posted in the question and use it as an answer? –  Code Bling May 30 '11 at 21:54
    
He he, it seems that I did. Why didn't any of the scripts mentioned in this thread work for you? After all, the posts did say that they managed to get QoS really working. –  harrymc May 31 '11 at 4:54
1  
How to limit Up/Dn speed using Script Generator without using DDWRT paid versions seems to hint that QoS is only easy on the paid version, maybe on purpose. –  harrymc May 31 '11 at 20:04
1  
Whatever. At least you now know where you stand and maybe have a way to avoid the paid version where QoS does work. Not bad for "legwork". Now what was the post about? –  harrymc May 31 '11 at 21:05
1  
@harrymc The article (...). So it seems that only the paid version of DD-WRT easily supports QoS. How does the fact there are additional QoS settings available in the paid version lead you to believe standard ones work there?? –  Piotr Dobrogost Aug 27 '11 at 7:33

You might want to study Toastman's work on QoS under Tomato. Apparently QoS is working there. As far as I know Toastman is managing an apartment building of users, so he has the experience. I never used Tomato without setting QoS up, so I can't say what would happen if I didn't!

share|improve this answer
    
I'm using Toastman's mod as well and it works very well, although what he did to QoS was just change the classes, as far as I know. QoS works fine in the upstream builds of Tomato, but his mod makes it work out of the box, without you having to fiddle around with thew configuration. –  paradroid May 23 '11 at 11:26
    
I'll check out his work but I am specifically only interested in DD-WRT for the moment (running OpenWRT right now and Tomato isn't supported on my router) –  Code Bling May 24 '11 at 15:57
    
Toastman (and now other tomato versions like shibby that implement Inbound QoS) are the only consumer QoS solutions I've seen that is worth writing about. They are sufficiently flexible that you can hammer your connection to hell and maintain you high priority traffic. Honestly, especially for aDSL (which needs TC-ATM patch), you will probably never get anything more than 'satisfactory' results from other consumer QoS solutions, besides tomato toastman and similar variants. –  cloneman Apr 2 '13 at 5:07

As of current the latest version of DDWRT on my WRT54Gv3 does not work. setup in GUI is solid, but it fails to actually do it's job, scripting is still needed! This popped up as a google result to my own same question. moved over to tomato after skimming answers. not as pretty GUI but QoS is working and testable within minutes.. QoS in DDWRT is fruitless if just using the GUI, sad as that may be. I would have loved to stay with it.

share|improve this answer
    
How did you test your setup? What was not working? –  Code Bling Jan 31 '12 at 22:49
    
Also, what version of DD-WRT were you using? –  Code Bling Jan 31 '12 at 23:08

DD-WRT v24-sp2 (08/12/10) mini - build 14929 installed on my Linksys WRT300N v1.1, QOS seems to work for some situations and not at all for others. I have myself set for premium and the young padawan set for bulk, yet when he starts downloading a steam game or xbox 360 game then it provisions him around 75% of the total connection. It does seem to work when he wants to watch youtube and I want to download a game myself. In the later scenerio he will get nothing and I will get everything :-)
I have read that this either has to with the processor or lack of ram. I have also read some place that unless you have the paid version of dd-wrt then you don't have QOS functionality. Ultimately, I'm totally confused.

share|improve this answer
    
Thanks for sharing your experience! –  Code Bling May 24 '13 at 5:33

I know this is somewhat "ancient history", but I found this question while troubleshooting my Vonage VoIP service through my DD-WRT box (Linksys WRT54G v2 running "v24-sp2 (10/10/09) vpn"). I was getting all sorts of weird results when I would click "Apply Settings" in the DD-WRT QoS web GUI. Sometimes I would apply the changes and then all HTTP(S) requests would fail.

I obtained consistent results by:

  1. Changing the settings
  2. Clicking "Save"
  3. Reboot the router (by clicking the "Reboot Router" at the bottom of the "Administration" tab)

My Vonage settings are:

  1. Use www.speakeasy.net/speedtest/ to get the upload and download speeds in kbps
  2. Take 90% of those values
  3. In the QoS web GUI, choose:

    • Start QoS: Enable
    • Port: WAN
    • Packet Scheduler: HTB
    • Uplink:
    • Downlink:
    • Optimize for Gaming: unchecked
    • Services Priority
      • sip: Premium
      • Add a service for “vonage” with UDP ports 10000-25000, and set it to Premium
      • http: Express
    • MAC Priority: add the MAC address of the Vonage SIP gateway as Premium
    • Ethernet Port Priority: the Vonage SIP gateway was connected directly to one of the ports on the DD-WRT, so I set it to Premium, and set all others to Standard

Hope this helps out the next person...

share|improve this answer
    
Thanks for the info! –  Code Bling Sep 16 at 21:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.