Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Hey, I've tried to install three things from source now, but after I close Terminal (Mac), they seem to 'disappear' and I can't use the commands that worked before.

The first was Node.js. I cloned the git repo into my Downloads folder, and followed the commands

make install

after which node worked. After closing and reopening node returns -bash: node: command not found.

The second was npm, which never worked, no matter which way I installed it. First I tried the one-liner: curl | sh but that didn't work, and cloning the git repo and sudo make install didn't work either.

The third was CoffeeScript.js which, after downloading, and compiling, didn't work either. Obviously installing it via npm wouldn't work either!

Any help would be GREATLY appreciated as I may be making some silly mistake.


share|improve this question

closed as off-topic by Breakthrough, teylyn, gronostaj, Tog, Shekhar Jul 29 '13 at 19:45

  • This question does not appear to be about computer software or computer hardware within the scope defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

Given the accepted answer and the age of this question, it serves absolutely no useful information for the community. – Breakthrough Jul 28 '13 at 18:16
up vote 1 down vote accepted

I just tried it again and it worked, so I have no idea what went wrong.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged .