Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have setup my laptop with Ubuntu 11.04. I bought a fresh SSD, and expected the startup time at <30 seconds but it takes about 3-5 minutes.

I have taken a snapshop using bootchart but I don't know exactly how to read it:

enter image description here

For me, it looks like modprobe is running in some sort of timeout - but where can I check this?

The boot from dmesg:

http://pastie.org/1937104

share|improve this question
    
i was very happy to see my own post about this 1 year later since i reinstalled ubuntu and then i searched for "slow startup time ubuntu modprobe" i did not remember this specific fix horray for superuser! – Andreas Petersson Sep 9 '12 at 19:49

Have a look at this bug report: tpm_tis 00:0a: tpm_transmit: tpm_send: error -62 (for Fedora, but since it's kernel related could apply to Ubuntu).

The workaround for the issue seems to be to add

tpm_tis.interrupts=0

to the kernel command line.

(If that doesn't work for you, make sure you have the latest update of the Ubuntu kernel installed.)

share|improve this answer
    
That did not work.. – Andreas Petersson May 21 '11 at 10:41
    
do you have the latest ubuntu kernel? did the dmesg output change at all? – Mat May 21 '11 at 10:42
up vote 1 down vote accepted

apparently one driver (tpm_tis) was blocking the startup. i tried editing /etc/default/grub

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash tpm_tis.interrupts=0"

but this did not work, dmesg did the same output.

but then i disabled the module tpm_tis alltogether by adding

blacklist tpm_tis

to /etc/modprobe.d/blacklist.conf this pushed startup down to 17s after bios - 31 seconds from cold start

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .