Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Hey guys, put your newbie-tolerance helmets on:

After installing Ubuntu 11.04 Natty on my lenovo s12, my broadcom bcm4312 wireless adapter doesn't work anymore, even when I load from windows 7!

How could this be? did it physically change something in my adapter config? Can I reset to factory setting?

Gory details: Installed 11.04 on second partition (dual boot mode), got "wireless is disabled by hardware switch", tried several other drivers (b43, ndiswrapper) to no avail, cursed, got back to my windows7, and wireless doesn't work there as well - got a red X on it, even when I jiggle the wifi on/off switch several times, restart, removed and re-installed the windows drivers, windows network diagnostics says: "radio is off" and its on on on! ran out of ideas, wept.

Pointers would be appreciated... what should I be looking for? Broadcom/Lenovo utils for hard resetting?

share|improve this question
up vote 4 down vote accepted

The Broadcom wireless adaptors load up firmware on the card/chip to help them run so it is possible that a software action can clobber the card - see here for some notes on the setup:

Although I have worked on Broadcomm kit under linux, I have never encountered this kind of problem but a few places to start include Broadcomm's support site:

I'd have a look for any Broadcomm tools supplied with the laptop, on the laptop manufacturer's site or at Broadcomm's to see if there are any adaptor setup/detection utilities. Meanwhile I'll have a poke around the 'net....

Edit: A bit of info from a similar problem -

I have installed ubuntu in my windows vista using wubi. Wireless isn't working in ubuntu, so I have to install Broadcom STA proprietary wireless driver and it works fine in ubuntu. when I reboot into windows, to my shock, hardware isn't been recognised in windows. This is not first time I experienced it. I had same problem when i installed nvidia drivers on another dell precision. Its graphics got screwed and never been recovered. I tried re installing windows but problem still persists. your suggestions are highly appreciable.

Try shutting down the machine and leaving it for a few moments before doing a cold boot into Windows. Don't do a warm reboot. Sometimes the wireless firmware doesn't load properly after doing a warm reboot from one OS to the other.

I don't think this would explain your nvidia card issue though.

share|improve this answer
great, windows7 is back online! cold reboot did the trick. However, I do wish to give ubuntu another try. Should I wimp out and go for Maverick instead of Natty? Or should I just use firmware-b43-installer and hope to get that firmware thingie right this time? – ihadanny May 21 '11 at 12:03
oops. Forget it! ubunu Natty works as well! and it appears to be doing this with the broadcom STA driver (so sayz the hardware->additional drivers tool). The only thing i might have changed is blacklisting acer_wmi. strange, but no longer frustrating! – ihadanny May 21 '11 at 12:16
Glad its working - I'll have to keep an eye out for this when I next put Ubuntu on a laptop. All the best. – Linker3000 May 21 '11 at 14:23

If the problem is affecting multiple operating systems, it is most likely to be BIOS or hardware-related. Try resetting your BIOS settings and see if that brings back functionality again. You may need to re-enable wireless in your BIOS after you nuke the settings.

share|improve this answer
kez, you just saved my 400$ machine! Thanks man, however linker3000 answer has more info - giving him the V. – ihadanny May 21 '11 at 11:52

It is possible, but highly, highly unlikely that a driver or any other software would damage your wireless adapter. Custom firmware that can up the voltage to a wireless adapter can damage the adapter, but that is not the case here.

It is more likely a coincidence that your network adapter failed at the same time you installed your new OS, or more likely that your switch is bad or something of that nature. If you have another laptop available try swapping the network adapters to see what happens.

share|improve this answer
ok, further data: in windows, my bluetooth-wifi-main on/off switch does display a big blue icon on the display of happy/sad connections when I jiggle it, and windows does a happy/sad sound, and the bluetooth does go on/off - so something still works (just not the wifi). About your suggestion - it's an onboard network adapter - how can I swap it? – ihadanny May 21 '11 at 11:03

there's a switch on your laptop, which is called RFKILL, you have flipped that by mistake. Look around your laptop and you'll find that switch, flip it back!

For eg on a thinkpad - the switch looks like this:

enter image description here

share|improve this answer
nice try :) that's not it, that's the switch i was jiggling. – ihadanny May 21 '11 at 11:50

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.