Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Example:

Lorem ipsum dolor sit amet, consectetuer adipiscing elit, sed diam nonummy nibh euismod tincidunt ut laoreet dolore magna aliquam erat volutpat. Lorem ipsum dolor sit amet, consectetuer adipiscing elit, sed diam nonummy nibh euismod tincidunt ut laoreet dolore magna aliquam erat volutpat

Turns into this when copying to Firefox browser:

Lorem ipsum dolor sit amet, consectetuer adipiscing elit, sed diam nonummy nibh euismod

tincidunt ut laoreet dolore magna aliquam erat volutpat. Lorem ipsum dolor sit amet,

consectetuer adipiscing elit, sed diam nonummy nibh euismod tincidunt ut laoreet dolore

magna aliquam erat volutpat

These are broken sentences. Don't know if it is only with Firefox though...

UPDATE: Here is how it looks like in Notepad

enter image description here

Here is how it looks in Firefox after copying from Notepad:

enter image description here

What i have found also is that if i open new Notepad document, write several sentences without line breaks and copy this to Firefox, the formatting retains and no unnecessary line breaks are added.

share|improve this question
1  
Not enough info. –  Ignacio Vazquez-Abrams May 21 '11 at 14:44
    
Screenshots please. –  slhck May 21 '11 at 14:49
    
it could just be a badly implemented word wrap you refer to.. I might've seen something like that once with a browser (not FF), and pasting into an email in my browser. The textbox was small, and the word wrapping added new lines.. that's what it seemed like anyway. though not sure. It'd help to see where it happened. 'cos different textboxes you paste into may behave differently. –  barlop May 21 '11 at 14:56
    
What operating system are you using? I think I remember really broken word wrap behavior on Windows XP (perhaps GM/SP1?) notepad.exe... –  Daniel Beck May 21 '11 at 16:08
    
I have added more details to my question. –  Boris_yo May 23 '11 at 6:21
show 2 more comments

4 Answers

up vote 2 down vote accepted

Check if you have "Word Wrap" in Notepad (Under "Format" menu). If it's on, turn it off!

You might have line breaks in your text, which you may miss if you have word wrapping on. If you have no line breaks, you should get all the text in one line in Notepad. And that can be pasted nicely into the browser.

enter image description here

share|improve this answer
    
But that means i will have to work without Word Wrap. Or disable it every time i want to copy from Notepad. –  Boris_yo May 23 '11 at 19:03
    
@Boris_yo: Yes, that's the case. Otherwise, you have no way of seeing line breaks in Notepad. Or, you could use another word processor, like Word, and enable showing "paragraph marks". –  TFM May 23 '11 at 19:46
add comment
 These are broken sentences.

Ah, but they are not. (At least not what you've posted here.)

Copy your text from this forum & paste it into Notepad.

You will see that it is one line of text, even if it happens to (look like) 3 individual lines.

If I take your text (as posted above), copy it into Notepad, & manually break the lines (at least as it appears in your post), & paste those (& they are then 3) lines back into here (this reply), I get 3 actual lines.

(I'll need to double space them as typed here, as the forum will automatically wrap the lines in the response. No I don't, just "coding" them should work, perhaps will not being quite as apparent?):

 Lorem ipsum dolor sit amet, consectetuer adipiscing elit, sed diam nonummy nibh euismod tincidunt ut
 laoreet dolore magna aliquam erat volutpat. Lorem ipsum dolor sit amet, consectetuer adipiscing elit, sed
 diam nonummy nibh euismod tincidunt ut laoreet dolore magna aliquam erat volutpat

I think what you may be "seeing" is this forum (possibly others too) is the automatic wrapping of consecutive (individual, separate, in our minds) lines of text.

share|improve this answer
    
I have added more details to my question. –  Boris_yo May 23 '11 at 6:21
add comment

In your Notepad screenshot, is Word Wrap enabled or not. Post another screenshot showing the alternate mode. You may discover your answer.

If I copy a set of lines from Notepad that are not wrapped, & paste them into this reply box, they display just as they were, individual lines. (Note that if I were to actually Post here, the forum would automatically wrap them regardless.)

If I copy a set of wrapped lines from Notepad & paste them into this reply box, they display wrapped.

So IMO the "problem" you are running into is how the source of your copy is formatted.

If the source are individual lines, what you paste will be individual lines. If the source is a single line (which is what a "wrapped" line actually is), what you paste will be a single line (that will appear wrapped.

(& again note that forums may, & this one in particular, wrap consecutive lines regardless of how they were copied/pasted into the reply box - unless you take measures to cause the formatting to change; like double-spacing between sentences or quoting the texts.)

share|improve this answer
add comment

I'm taking a shot in the dark here, but it could be the EOL (End of Line). Notepad formats the text with CR+LF (/r/n), but firefox might expect just LF (/n).

share|improve this answer
    
I have added more details to my question. –  Boris_yo May 23 '11 at 6:21
    
I have no idea why I was downvoted, but I've had the same exact issue when copying and pasting CR+LF text into a text editor expecting LF. I still stand by my answer. –  Bandit May 23 '11 at 13:06
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.