Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I use this line to convert the mov file (Mark II 5D footage) to 720p:

ffmpeg -i source.mov -s 1280x728 -vf crop=1280:720:0:0 -sameq -acodec copy dest_file.mov

When I drag the result file to premiere, I can only hear the first 17 frames of audio. It's the correct audio, but I don't know why premiere thinks the rest is silence. The result file plays well in CS3 and VLC.

This is the source file in MediaInfo:

General
Complete name                    : E:\Stuff\TopLessProductions\Testing2011\Raw\MVI_9019.MOV
Format                           : MPEG-4
Format profile                   : QuickTime
Codec ID                         : qt  
File size                        : 173 MiB
Duration                         : 31s 800ms
Overall bit rate                 : 45.5 Mbps
Encoded date                     : UTC 2010-06-17 09:24:40
Tagged date                      : UTC 2010-06-17 09:24:40

Video
ID                               : 1
Format                           : AVC
Format/Info                      : Advanced Video Codec
Format profile                   : [email protected]
Format settings, CABAC           : No
Format settings, ReFrames        : 1 frame
Codec ID                         : avc1
Codec ID/Info                    : Advanced Video Coding
Duration                         : 31s 800ms
Bit rate mode                    : Variable
Bit rate                         : 44.0 Mbps
Width                            : 1 920 pixels
Height                           : 1 080 pixels
Original height                  : 1 088 pixels
Display aspect ratio             : 16:9
Original display aspect ratio    : 16:9
Frame rate mode                  : Constant
Frame rate                       : 25.000 fps
Color space                      : YUV
Chroma subsampling               : 4:2:0
Bit depth                        : 8 bits
Scan type                        : Progressive
Bits/(Pixel*Frame)               : 0.849
Stream size                      : 167 MiB (97%)
Language                         : English
Encoded date                     : UTC 2010-06-17 09:24:40
Tagged date                      : UTC 2010-06-17 09:24:40
Color primaries                  : BT.709-5, BT.1361, IEC 61966-2-4, SMPTE RP177
Transfer characteristics         : BT.709-5, BT.1361
Matrix coefficients              : BT.601-6 525, BT.1358 525, BT.1700 NTSC, SMPTE 170M

Audio
ID                               : 2
Format                           : PCM
Format settings, Endianness      : Little
Format settings, Sign            : Signed
Codec ID                         : sowt
Duration                         : 31s 800ms
Bit rate mode                    : Constant
Bit rate                         : 1 536 Kbps
Channel(s)                       : 2 channels
Sampling rate                    : 48.0 KHz
Bit depth                        : 16 bits
Stream size                      : 5.82 MiB (3%)
Language                         : English
Encoded date                     : UTC 2010-06-17 09:24:40
Tagged date                      : UTC 2010-06-17 09:24:40

This is the result file in MediaInfo:

General
Complete name                    : E:\Stuff\TopLessProductions\Testing2011\Resized\brMVI_9019.MOV
Format                           : MPEG-4
Format profile                   : QuickTime
Codec ID                         : qt  
File size                        : 47.7 MiB
Duration                         : 31s 800ms
Overall bit rate                 : 12.6 Mbps
Writing application              : Lavf53.1.0

Video
ID                               : 1
Format                           : MPEG-4 Visual
Format profile                   : Simple@L1
Format settings, BVOP            : No
Format settings, QPel            : No
Format settings, GMC             : No warppoints
Format settings, Matrix          : Default (H.263)
Codec ID                         : 20
Duration                         : 31s 800ms
Bit rate mode                    : Constant
Bit rate                         : 11.1 Mbps
Width                            : 1 280 pixels
Height                           : 720 pixels
Display aspect ratio             : 16:9
Frame rate mode                  : Constant
Frame rate                       : 25.000 fps
Color space                      : YUV
Chroma subsampling               : 4:2:0
Bit depth                        : 8 bits
Scan type                        : Progressive
Compression mode                 : Lossy
Bits/(Pixel*Frame)               : 0.480
Stream size                      : 41.9 MiB (88%)
Writing library                  : Lavc53.6.0
Language                         : English

Audio
ID                               : 2
Format                           : PCM
Format settings, Endianness      : Little
Format settings, Sign            : Signed
Codec ID                         : sowt
Duration                         : 31s 800ms
Bit rate mode                    : Constant
Bit rate                         : 1 536 Kbps
Channel(s)                       : 2 channels
Sampling rate                    : 48.0 KHz
Bit depth                        : 16 bits
Stream size                      : 5.82 MiB (12%)
Language                         : English

Anybody have an idea what to do? A workaround for me was to avoid "-acodec copy" and use:

-ab 256k

Which means aac. But I wonder if there's a real solution or an idea as to why Premiere is acting up, or how to analyze the difference between the 2 audio streams metadata.

share|improve this question
add comment

migrated from stackoverflow.com May 21 '11 at 22:32

This question came from our site for professional and enthusiast programmers.

1 Answer

Why don't you just use Premiere to convert it to 720p? Seems that it is incompatible with ffmpeg...

share|improve this answer
    
I'm using ffmpeg to batch convert a large amount of videos and extract the audio at the same time. The strange thing is it worked great in all previous versions of premiere. –  ubershmekel May 22 '11 at 20:41
    
@ubershmekel: Ah, you could try to see if other options for ffmpeg help you then or something, I don't know enough of it to help you further. Incompatibility is a bad thing, but it happens... :( –  Tom Wijsman May 22 '11 at 20:46
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.