Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My motherboard, (Asus P8Z68-V PRO), has Bluetooth built in, but for some reason Windows 7 64-bit will not recognize it. By this I mean it doesn't even show up in the Device Manager as a yellow question mark/exclamation mark. I have tried it with the drivers installed (that came with the motherboard) and without (to try to use the windows default), but the Bluetooth will just not be recognized.

This means that even when I install the drivers, nothing happens because Windows doesn't seem to think there are any Bluetooth radios on the computer to begin with. So installing/uninstalling drivers has no effect on this issue.

I know the Bluetooth is fine, because I have tried it in other operating systems on the same computer, such as Ubuntu 10.10 (Maverick Meerkat), which instantly detected it and even paired with some of my devices when I told it to. So it seems that somehow something is messed up on the Windows end.

My general question is, when something is definitely there (I mean, it's soldered on) and you've proved it's not faulty (it works in other operating systems), what can you do in Windows to somehow fix this?

I'm wondering if there's any way to sort of 'purge' or refresh Windows' device recognition, since I would prefer not to reformat.

Supplementary Information: This is a new motherboard (the latest model from Asus for the latest Intel chipset, Z68), for which there are Windows 7 64-bit drivers, so I know it's not an issue of incompatibility.

In fact, I had an Asus P8P67 Deluxe before this which also had the Bluetooth built in. I believe the reason for this issue is that I simply swapped it out for the Z68 board, so there was possibly somehow a conflict.

Everything else is working fine by the way.

share|improve this question
  1. Go to the motherboard downloads page, select Windows 7 (64-bit).

  2. Install Intel Chipset Inf Update Program V9.2.0.1021

  3. Install Atheros Bluetooth Driver V7.2.0.40 for Windows 7 32bit & 64bit.(WHQL)

If that doesn't help on a clean installation it sounds like there is an incompatibility problem.

Log files that could help to diagnose are C:\Windows\inf\ and

share|improve this answer
Thanks, but that didn't seem to do anything different. I'm currently going through the setup logs in hopes I can find something (they're huge), but like I said in my post, I don't believe it's an installation problem. It seems like at some other (lower ?) level, windows just doesn't know there is a bluetooth radio there to associate with the drivers I'm installing, so nothing happens. – Jorge Israel Peña May 23 '11 at 5:51

I had the same problem. You need to enable the Bluetooth in the BIOS. In my BIOS (I think I have the same motherboard or a similar one) I had to go to advanced options to turn it on.

Save and restart, and Windows can now see it. Then you just need to install the drivers and so on.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .