Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Ocassionally aero effects crash. Is there a way to re-enable the effects in Windows 7 after a crash happens?

i.e. restarting a service or terminatating a process and letting it restart automaticially or manually loading it?

Problem symptoms; in

Control Panel \ Appearance and Personalization \ Personalization

The standard "Window Color" option is not available it just appears as "Basic"

Reboot will solve this issue, but would like to avoid that if possible.

share|improve this question
2  
sage- You need to run the command window elevated (right click, run as elevated). That will take care of the "Access denied" messages. –  user114197 Jan 18 '12 at 10:45
    
@davenpcj - Same here, especially when my question states that I want to find another solution, apart from restarting; Also, if one asks a question where rebooting is an option, I might let a comment to this effect go, but having an answer to a question (Which might stop others looking at it) like this, is annoying. One just needs to find someone with an intricate enough understanding of the system in question, in order to get a great, insightful, StackExchange-like answer... like Diago below, infact! –  user66001 Oct 8 '13 at 20:23

6 Answers 6

up vote 101 down vote accepted

Restart DWM with (by using a CMD shell window with Administrator permission):

net stop uxsms
net start uxsms

It's the same service that crashes and is also known as the Desktop Windows Manager.

share|improve this answer
    
No re-installing anything, no fiddling with the registry, just two commands in an elevated command prompt. Why doesn't Windows 7 make this simple solution so much more apparent? The Stack Exchange network is top-notch. +1! –  David Frye Aug 17 at 23:43
    
Put the commands into a .bat file, make a shortcut to the .bat file , click properties and put "explorer" before the path. Now it became a shortcut to a .exe and you can pin it to the startbar! You can even change the icon, to make it easy to see. Mine is an ancient "printer error" icon that felt somehow appropriate. –  Lodewijk Sep 30 at 1:32
    
I've created a .bat file, you can download it here. –  RienNeVaPlu͢s Oct 21 at 8:07

"taskkill /f /im dwm.exe" always did it for me, though Diago's answer is cleaner. Killing the process should get the DWM's helper service to restart it pretty much right away.

share|improve this answer
    
Turns out sometimes the helper service crashes too. dwm.exe was missing from the process list on my system, and I couldn't run it manually, but Diago's answer worked. –  davenpcj Jul 31 '12 at 18:06
    
This worked for me, where Diago's didn't, thanks! –  Danny Beckett Nov 10 '13 at 21:50

For me, when that happens I also have a wrong screen resolution. After I set it to the right resolution, in the Settings I can chose Aero as the Design again.

share|improve this answer
    
Sometimes an old application that switches the color scheme to 16-bit will crash. Having your colors set to 16-bit (instead of 32-bit default) will prevent you from turning on Aero. I was able to change it back in my NVIDIA control panel. –  cloneman Mar 25 '13 at 23:55

Neither of the aforementioned ways made my Aero restart, but after looking at a microsoft help page -- which suggested checking if Aero is broken on another user account as well -- and logging into that other account, Aero worked on my "normal" account as well.

share|improve this answer
  1. In Control Panel in search box type "aero"
  2. Click "Troubleshooting> Find fix problems with transparency and other visual effects"
share|improve this answer

Force Enable Aero in Windows 7

  1. Click on Start and type regedit at run

  2. Now Navigate to the following registry key:

    HKEY_CURRENT_USER\Software\Microsoft\Windows\DWM

  3. In the right details pane, create following Three DWORD (32-bit value) entry

UseMachineCheck, and set its value to 0.

Blur, and set its value to 0.

Animations, and set its value to 0.

  1. Close Regedit

  2. Click on Start and type CMD with administrative Priviliges

  3. Now type following command

Net Stop uxsms

Net Start uxsms

Above command will stop and start Desktop Window Manager Session Manager.

  1. Now you can turn on Aero by right clicking on the Desktop-> Personalize -> Select Windows Colors
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.