Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a project that should be available only through ssl connection. It's being served by Lighthttpd, but I can't figure out how to set up the ssl on the port.

When I use the guides I find with google, lighthttpd tells me that the port/socket it's attempting to use is already bound (I'm using port 8080). This is no mystery since it's serving normal http on that port.

I could bind 'http' to a different port, but I really don't want unused/listening ports lying around willy nilly :)

My question is if and how I can disable the 'http' serving, and only use https with ssl (preferably only on the vhost I've configured)?

share|improve this question
    
I see now that SSL won't let me have ssl on one vhost name only, but this is not really a problem since it's only serving this one project. So my question is now; how do i disable http so only https is used? –  Kanonskall May 21 '11 at 23:55
    
Well. All i had to do was add ssl.engine = "enable" and ssl.pemfile = "/<path>/<to>/>my>/<cert>.pem" to lighthttpd.conf... Now it no longer responds to http, only https. –  Kanonskall May 22 '11 at 2:59
    
If you find a solution yourself, post it as an answer, not as a comment. –  grawity May 22 '11 at 13:53
    
Sorry, i think i was unable to do that because there was a time set on how fast i could answer my own question. –  Kanonskall May 29 '11 at 22:54
add comment

1 Answer

up vote 1 down vote accepted

Add

ssl.engine = "enable"
ssl.pemfile = "/<path>/<to>/<my>/<cert>.pem"

to lighthttpd.conf

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.