Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I tried to install Ubuntu on my Acer Extensa 5420 laptop. At the point where Gparted should allow me to select partitions I could not see my Windows partitions with Vista and XP installed on them. It was written that the disk has no operating systems installed.

After googling I found out that this behavior may be caused by SATA drive with suggestions to change settings in BIOS. My BIOS does not provide means to change such settings. Has anyone here encountered the similar problem? Any suggestions how to install ubuntu? I have two partitions on my HDD and about 35GB of unallocated space.

sudo parted -l resulted with Error: /dev/sda: urecognised disk label (that's the disk with windows), and correctly recognized ubuntu live usb drive.

sudo fdisk -lu /dev/sda returned nothing but prompt for the next command. When I boot Ununtu Live in "try" mode and run Gparted it sees only the drive with Live USB. It does not see sda drive. But the disk utility detects HDD with Windows.

Any help would be appreciated.

Update: sudo fdisk -l lists only USB drive:

Disk /dev/sdb: 4005 MB, 4005560320 bytes
124 head, 62 sectors/track, 1017 cylinders
Units = cylinders of 7688 * 512 = 3936256 bytes
Sector size (logical/physical) 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00c875f

   Devise Boot    Start     End     Blocks     Id    System
/dev/sdb1   *         1    1017    3909317      c    W95 FAT32 (LBA)

Update #2: This is the output of list disk from Vista (I have moved unallocated space on the disk to one of the partitions since I posted my question here):

Partition ###  Type           Size        Offset
-------------  -------------  ----------  -------
Partition 1    OEM                 10 GB  1024 KB
Partition 2    Primary            112 GB    10 GB
Partition 3    Primary             92 GB   121 GB
Partition 0    Extended            20 GB   213 GB
Partition 4    Logical             20 GB   213 GB

Update #3: Here is the screen shot of disk manager:

(Click image to enlarge)

share|improve this question
I recommend also telling people what you get when you boot into Windows NT, run diskpart, select your disc, and run the list partition command. – JdeBP May 24 '11 at 13:16
Thanks. I've done it. – bancer May 24 '11 at 14:11
Do you have dynamic disks enabled? Open Disk Management and post a screenshot. – Hello71 May 28 '11 at 2:32
Dynamic disks are not enabled because I have Vista Home (they are supported only by Vista Enterprise and Vista Ultimate). – bancer Sep 20 '11 at 18:14
Very weird regarding the BIOS. The SATA AHCI/ATA setting is not present anywhere? – Noam Kremen Sep 20 '11 at 19:06

Couple different things I would try.

First, try burning your Ubuntu ISO to a disk, or even a GParted Live CD would work. On occasion GParted will lock up if you're booting from a drive - I'm not sure why, but I've seen it happen before.

Once you're in from there, run

sudo fdisk -l

(Don't specify the drive)

Make sure that the drive you're looking for is /dev/sda - it may actually be /dev/sdb or /dev/sdax or something similar to that. If you do see your drive you can try doing an Ubuntu install right there, or if it still doesn't work, it may be helpful to actually partition your HDD outside of the ubuntu installer (launch a standalone GParted and do it).

If it's still not working, paste the output of that fdisk command and we will continue debugging.

share|improve this answer
When I run sudo fdisk -l from Live CD it produces no output. When I run it from Live USB it lists only USB drive (sdb): Disk /dev/sdb: 4005 MB, 4005560320 bytes (See update in the question above). – bancer May 24 '11 at 13:49
I would not like to repartition the disk. I want to keep Windows and install Ubuntu as another boot option. – bancer May 24 '11 at 14:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .