Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I need permission to move or copy or open or really do anything to this one .dll file which I NEED to move, it's located on a mounted .iso.

I've tried

  • using administrator log in and it won't allow me to do anything with the file
  • takeown in CMD
  • looking at the folder properties that the file is contained in for security settings, and the folder only has "general","sharing","customize" tabs.
  • every answer to this question i've seen, and none have worked

Some extra info: Yes, the security tab is visible in other folder properties

share|improve this question
    
It would be helpful to know how is the .iso mounted - Daemon Tools? VCDControlTool? built-in Windows feature? – grawity May 22 '11 at 12:28
up vote 2 down vote accepted

An ISO-9660 filesystem is usually read-only, and the only way you can modify it (whether it is a CD or an .iso image) is to extract all files and rebuild, or to use a tool such as WinImage or MagicISO.

(The "Security" tab is not visible because ISO-9660 does not support it.)

If you cannot even read a file, it might be caused by

  • another program keeping it open and locked; try Process Explorer or Unlocker;
  • an antivirus gone mad;
  • the filesystem being corrupted.

Unmount the image and open it in MagicISO or WinImage, then see if you can access the file.

share|improve this answer
    
I'm curious, how did you deduce that the filesystem is ISO-9660? – Sathya May 22 '11 at 12:28
    
@Sathya: Quote from the question: "it's located on a mounted .iso." (It may be a UDF image of a DVD, yes, but the same restrictions apply: read-only and no Windows-compatible ACLs.) – grawity May 22 '11 at 12:30
    
d'oh - missed that line. – Sathya May 22 '11 at 12:31
    
problem solved! I opened it in WinImage and it worked immediately, thank you very much! – Ali May 22 '11 at 12:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .