Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Host machine (desktop) runs XP and the client (netbook) runs 7.

It worked a few months ago but now refuses to give the client internet access.

ipconfig on host machine straight after a reboot:

Ethernet adapter Local Area Connection:

    Connection-specific DNS Suffix  . :
    IP Address. . . . . . . . . . . . : 192.168.1.100
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Default Gateway . . . . . . . . . : 192.168.1.254

Ethernet adapter Wireless Network Connection 4:

    Media State . . . . . . . . . . . : Media disconnected

Firstly it's weird how it says "Media disconnected" because the wifi adapter is plugged in and connected to the ad hoc network.

If I turn on wifi on the netbook and connect to the ad hoc network with the right key, the host acquires 255.255.255.0 / 192.168.0.1.

On the netbook, I had to manually assign the wifi adapter config as follows: 255.255.255.0 / 192.168.0.2. with a gateway of 192.168.0.1. This is because before it was acquiring a strange subnet mask and ip, for some reason.

Both machines can ping each other! But client can't get internet. I have allowed the internet connection on the host to be "shared" etc etc.

Any ideas where the problem might lie?

Apologies if this is a scrambled question, I'm not a network tech, just do it hands-on trial and error.

share|improve this question
    
"This is because before it was acquiring a strange subnet mask and ip, for some reason." That happens because your desktop is not running a DHCP server. It is normal. –  Bandit May 22 '11 at 18:09
    
Have you gone over the document "Ad Hoc Internet Sharing with Microsoft Windows XP" provided by Microsoft? –  Ƭᴇcʜιᴇ007 May 22 '11 at 20:56

1 Answer 1

The first thing I recommend you try is to disable sharing and unplug the WiFi adapter (is it USB or what?) From there, just plug the WiFi adapter back in and turn on sharing. Maybe it was a glitch that can be solved by just resetting everything up.

share|improve this answer
    
Yeah it seems like the ICS is engaging before the Ad-hoc and therefore is confused. :) –  Ƭᴇcʜιᴇ007 May 22 '11 at 20:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.