Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Macbook Pro running Snow leopard and when on a static broadband Maps loads well. We take the laptop on our boat and using an O2 Dongle we can download most things given a good signal. Until September last year we were able to download maps sometimes slowly but with a good signal nearly as good as a fixed signal. Since September we have been unable to download maps. What happens is that the home page mostly loads but then on entering any search criteria it tries to load for a second or two then stops and does not bother to go any further. There is an error message at the top of the screen it states "Still loading... Slow? Use the troubleshooting guide or basic HTML."

None of which helps

As far as I can work out it seems either Google have altered their system or O2 have somehow decided to block some of the details required to load maps.

Can anyone help?

share|improve this question
    
RE: "Still loading..." -- Have you tried waiting (a long time) to see if it eventually loads? –  Ƭᴇcʜιᴇ007 May 22 '11 at 19:57
    
What is the speed of the internet with the dongle? Use speedtest.net to measure your connection speed. Location can also have an effect on speed; it may be fast at home, but it might not be in another location. –  evan.bovie May 22 '11 at 20:51

3 Answers 3

There's a lot of different things that could be causing this. I'll start with the main ones that come to my mind.

It's possible you've got some crazy temp file, cookie, or other weird file that is hanging up when you try and load a map. Don't be offended by this suggestion - I have to assume the worst - have you restarted your computer since September? If not, do that. If it still doesn't work, clear all of your cookies, history, etc. from your browser. If it still doesn't work, you'll need some cleanup software. I don't have a mac, so I don't have any great recommendations, but I've heard, onyx is good.

It could just be that your connection is getting extremely slow. Perhaps something happened on O2s side, and they cut some bandwidth where you're located. Do as techie007 and emb1995 said - do a speedtest and try waiting a really long time for it to load (20 minutes should work). Post back here with the results of your speedtest and we will let you know if those are good or bad.

The next could be that there could be some sort of packets being sent from google maps that are getting lost in your O2 device, or in O2's network. I know that Google has been making changes to their maps service to speed things up, and maybe one of these changes didn't work well with O2. This is the least likely of the three, but because O2 is not a major internet service provider (they specialize in phones, right?) it is possible that they have shady service. I would give them a call and see if they have any suggestions, or if they can look into the issue. Perhaps try going to your local rep and asking for a replacement device to see if it is just an issue with your specific device.

share|improve this answer
    
Thanks Folks,Im not offended in the slightest. –  Malcolm Blundell May 23 '11 at 6:53
    
I would like to clarify however that we dont use the boat in winter so the laptop is connected to home broadband and maps works fine. I have cleared out history and cache and cookies, several times. I am fully aware that location is everything. We have edge, GPRS and 3G signals but it makes no difference when we use the dongle maps wont load even after 20 mins they just stop. Occasionally the header bar appears after a short while say 2 minutes but as soon as a postcode is input then within 20 seconds it stops loading. –  Malcolm Blundell May 23 '11 at 7:02

Apparently this problem is 'known" and replicated with other operating systems and dongles. I have used a partial fix as described by Ben Vallack (see How to fix poor image quality (compression) when using T-Mobile Web 'n' Walk on a Mac). He uses firefox with an add on program called "modify headers" I followed his instructions, not forgetting to tick the box "always on" kindly added on as a comment. Whilst my default browser is Safari the ability to load google maps utilising Firefox is now available to me on my laptop. Still slow in places but working.

A good solution to the problem (whatever that may actually be).

Thanks to you all Malcolm

share|improve this answer

Try loading OpenCPN. A brilliant free to use navigation software system. Next version should have a Google Maps interface. Currently OpenCPN reads most raster and vector charts.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.