Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a PC that once had Ubuntu Linux installed on it across 2 SATA hard drives.

The first hard drive had the root ( / ) and swap on it.

The second had ( /home ) directory as mount point. This has a large amount of data on it, formatted in ext4 I believe.

I decided to remove the first hard drive and replace it with another, and installed Windows 7 Ultimate on it. I kept the second hard drive in the PC because I want to format it into NTFS and use it as a backup/storage drive.

After installing Windows 7 on the new first drive, in Computer Management it doesn't see the other hard drive.

How can I get Windows 7 to detect and see the second hard drive in Computer Management? I would like to format it into NTFS-- Note: I do not want to have Win7 read/write to the linux filesystem, nor do I care to keep the files on it intact. I am fine with losing them since I have them backed up.

share|improve this question
    
does the bios show 2 harddisks? –  freethinker May 23 '11 at 8:04
    
If the partitions dont show in Computer Management, does the Disk itself show? –  Spectre May 23 '11 at 8:48
    
@freethinker the BIOS did show the hard disks, but they were disabled somehow. That was the problem. –  sunpech May 23 '11 at 19:59

2 Answers 2

up vote 2 down vote accepted

You can directly try the 3rd step here, but if you don't see your second disk, you'll need to go to BIOS and recheck starting from there.
1. Reboot and enter BIOS settings.
2. Confirm second disk is visible.
3. Boot into Windows 7 and reach Administrative Tools, Disk Management
Delete the second disk partition and reformat it to your choice.

Just in case you are wondering, you can read your ext4 partition data with Ext2Read.
And, if you don't see your second drive in step 1 above, you might want to start from checking the cables in your PC -- you may have left them unplugged while changing drives :-)

share|improve this answer
    
Thanks. The answer was that the BIOS somehow had this SATA drive disabled, which is certainly weird how my previous install of Ubuntu it was working. After enabling it, I booted up Win7 again and the drive was visible and available to be formatted. –  sunpech May 23 '11 at 17:46

Simply insert win 7 CD, go to run setup, it will show all partitions, delete partition and create new (store your data first), and install win7.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.