Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Ok, this is driving me crazy. My parents have 100s of old WPS documents from an ancient version of MS Works, and they just bought a new computer with MS Word 2010 Starter on it. I ap trying to set it up so that the default program to open the WPS files is MS Word, but there is no EXE anywhere in program files or programfilesx86. I opened up process explorer and tried to figure out where the executable for Word is, and it turns out it is on the Q drive... the same Q drive that seems to be inaccessible no matter what I try. I tried adding the exact address of Word, but if I try and set that on anything, it says that it cannot find the file. This is driving me insane, is there any way to make it real easy to open these WPS files in Word?!?

share|improve this question
WPS is also known as a famous free office software for personal use developed by Kingsoft in China. – LiuYan 刘研 Jun 23 '11 at 5:03
up vote 2 down vote accepted

oh my, the q drive? App-V! Seems like this gives a wee background on your setup.

Basically, this program isn't "installed" on their computer, rather, it is running in a virtual sandboxed environment from the Q drive making it a real rascal with file association.

Since I don't have the same set up as you, I can't try any of the below out, so, no promises:

Try the instructions found here, seems it'll fix your dilemma. Instead of locating excel.exe though, you should look for winword.exe inside the office14 folder.

After doing a bit of a search, I also found this thread on Microsoft Answers where a recent post by Angloblaxon gives a registry-based solution. You need to save the following to a text file with .reg extension, double-click it and say "yes" to importing into the registry:

Windows Registry Editor Version 5.00
"Content Type"="application/msword"
share|improve this answer
What the?? Just tried that, and at least now I have access to the Q Drive, but I didn't see winword or excel... I even did a search of the while Q drive for .exe, and nothing came up. What gives? Where the heck are these things running from? and yes, i did have show hidden folders and even show system files and folders, yet still... nothing! Any suggestions? – Sean May 24 '11 at 4:56

Just as Jonas put in the thread above my solution seems to work. i also found another link if this one is giving you trouble

This one seems to have built off of my original idea (allowing spreadsheets to work) and may prove to be better. I have not tried this one so please use at your own risk :)

share|improve this answer

I opened Microsoft starter, after I put in my usb with wps files. then I opened a blank page in Microsoft word starter and opened a file from my usb in the library and put it in word 6 - 9 (*.wps). It cautions it may change the file. Then I saved my wps in word 6.

share|improve this answer
Not very practical if you have 100s of documents and, at least for my parents, could be a challenge to navigate to the correct folder where the documents are located. – hydroparadise Jan 27 '12 at 15:21

Other possibilities are to use some open-source tools to convert the files into something more palatable to current editors. You might try this link for some hints on getting into WPS files.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .