Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

According to Synaptic package manager I have version 1:7.3+10ubuntu10.2 of both xorg and xserver-xorg, the latest version. I am trying to install gtk+3.0.0 and when I run 'make' it works until this point where I get the following:

make  all-recursive

make[3]: Entering directory `/home/administrator/source_files/gtk+-3.0.0/gdk'

Making all in x11

make[4]: Entering directory `/home/administrator/source_files/gtk+-3.0.0/gdk/x11'

  CC     gdkapplaunchcontext-x11.lo

In file included from gdkapplaunchcontext-x11.c:29:

gdkprivate-x11.h:45:36: error: X11/extensions/XInput2.h: No such file or directory, xorg, xserver-xorg 1:7.3+10ubuntu10.2, latest version is 1:7.3+10ubuntu10.2 (synaptic)

In file included from gdkapplaunchcontext-x11.c:29:

gdkprivate-x11.h:243: error: expected ')' before '*' token

make[4]: *** [gdkapplaunchcontext-x11.lo] Error 1

make[4]: Leaving directory `/home/administrator/source_files/gtk+-3.0.0/gdk/x11'

make[3]: *** [all-recursive] Error 1

make[3]: Leaving directory `/home/administrator/source_files/gtk+-3.0.0/gdk'

make[2]: *** [all] Error 2

make[2]: Leaving directory `/home/administrator/source_files/gtk+-3.0.0/gdk'

make[1]: *** [all-recursive] Error 1

make[1]: Leaving directory `/home/administrator/source_files/gtk+-3.0.0'

make: *** [all] Error 2
share|improve this question
6  
Don't edit "SOLVED" into your title or post. Post the solution as an answer. – ChrisF May 24 '11 at 16:12
    
I had tried but got a message that I would not be able to until after 8 hours. So I put it into to the post so people would know right away. – snooper May 26 '11 at 1:43
    
In that case add a comment to the same effect. – ChrisF May 26 '11 at 7:57

snooper's own solution:

3.0.0 was an older version of gtk+3, I was informed that there was a bug fixes that is now a macro around the inclusion of the file "X11/extensions/XInput2.h". I was able to install 3.0.10 without any problems.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .