Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When trying to run my executable I kept receiving an

error 404.2 error
The page you are requesting cannot be served because of the ISAPI and CGI Restriction list settings on the Web server.

I fixed it by going into the ISAPI and CGI Restrictions screen off of the server level in the IISManager, Clicking on the Edit Feature Settings link on the right in the actions box, then checking to allow unspecified CGI and ISAPI modules.

However I would like to know the correct way to make this work? I am thinking there is a restriction I need to add (and of course set to allow) to specify which module to run?

share|improve this question
up vote 0 down vote accepted

One the Restrictions screen what you are supposed to add is the path to the web service (File) that you want to be able to run.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .