Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've been using this ASUS p6t deluxe + i7 920 + 3x2gb G Skill DDR3 1333 for more than 2 years without any issue. A few months ago, I added 3 more dimms, the exact same brand and model, bought from the same vendor and when I put them, strange things started to happen. Putting 5 dimms gave me 10gb, but putting 6 dimms gave me 8 or 4gb. The strange thing is that in bios it reads that low number, but Everest or similar windows tool will show all the dimms populated.

I've been fighthing with this issue for a while, and I'm not alone. http://i4memory.com/ramdetect/

HERE is the strange thing. I found out a workaround: when starting the computer on the morning, it will detect 4gb only. Entering in the bios and changing from 1333 to 1666, and then exiting the BIOS makes the machine to turn off and on again, and there you go, 12gb. But next day it will happen again. only 4gb. So, the same procedure works. go to bios, change again from 1666 to 1333 and voila.

Of course this workaround its really unfriendly, so I'm looking for any clues on WHY this workaround works?

Things already tried:

  • Changing dimms from bank to bank
  • Rotating
  • Pushing harder
  • Loosing/tightening CPU cooler screws
  • Changing (elevating) voltages of RAM and CPU
  • Loosening timings from RAM spd
  • Bios is 2101 , there is a new one but only adds support to new cpu's

This happens with no overclocking or any other non default settings too. Any thoughts?

share|improve this question
    
It is almost definitely a BIOS settings issue. I'd guess you need an additional CMD state. –  David Schwartz Aug 8 '13 at 4:58

2 Answers 2

I'm guessing its a BIOS bug, make sure your BIOS is up to date. Check here for the latest BIOS versions (here if you have V2 of this board).

If the problem still persists you could contact Asus about it, see if they can replicate the issue. Apparently they know and suggest you RMA the motherboard.

EDIT: Lots of people seem to have this problem, things to try align with basically what you have stated. One suggestion is to try removing and re-inserting the CPU (of course you'll probably have to replace the thermal paste between CPU and heatsink if you do this). Also, in the BIOS try setting 'AI Overclock Tuner' to 'X.M.P'.

If you still can't get it working, might have to RMA the motherboard.

share|improve this answer
    
What's really strange is that it worked flawlessly with 6gb till I added another 6gb. An the thing that toggling from 1333 to 1666 or viceversa corrects the issue, it's strange too. RMA'ing it's not an option as it's more than 3 years old :( –  andres May 26 '11 at 13:54

this worked for me when upgrading from 6GB to 12GB:

In bios set "Dram bus voltage" to 1.64v and "QPI/Dram voltage" to 1.35v

I had to shutdown the computer completely for it to take effect.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.