Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have installed OpenSUSE on VMWare player as guest OS and my host OS is Windows XP. What I want to achieve is to send message from my host (i.e XP), say on port 7000 and receive it on a specific port on my guest, i.e. OpenSUSE, say on port 10000. I have a software using which I can send any message on a specified port. (That software uses TCP.)

I am pretty sure that I am not the first person on earth who is facing this scenario. But I am pretty new with this VMWare player and even OpenSUSE. Can anyone guide me with this?

EDIT 1:

Output of ifconfig on OpenSUSE:

Directory: /root
Tue May 24 14:58:18 EDT 2011
linux-gyuz:~ # ifconfig
eth0      Link encap:Ethernet  HWaddr 00:0C:29:B9:F4:AF  
          inet addr:192.168.206.128  Bcast:192.168.206.255  Mask:255.255.255.0
          inet6 addr: fe80::20c:29ff:feb9:f4af/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:4621 errors:0 dropped:0 overruns:0 frame:0
          TX packets:903 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:6379045 (6.0 Mb)  TX bytes:75021 (73.2 Kb)
          Interrupt:19 Base address:0x2000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:72 errors:0 dropped:0 overruns:0 frame:0
          TX packets:72 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:4960 (4.8 Kb)  TX bytes:4960 (4.8 Kb)

linux-gyuz:~ #                                                                                                                                                                                                                               

EDIT 2: Output of ipconfig /all on XP:

Windows IP Configuration

Ethernet adapter Local Area Connection:

    Connection-specific DNS Suffix  . : mycomp.com
    IP Address. . . . . . . . . . . . : 205.142.113.181
    Subnet Mask . . . . . . . . . . . : 255.255.254.0
    Default Gateway . . . . . . . . . : 205.142.112.1

C:\Documents and Settings\user>ipconfig /all

Windows IP Configuration

        Host Name . . . . . . . . . . . . : R8PPAV7
        Primary Dns Suffix  . . . . . . . : mycomp.com
        Node Type . . . . . . . . . . . . : Peer-Peer
        IP Routing Enabled. . . . . . . . : No
        WINS Proxy Enabled. . . . . . . . : No
        DNS Suffix Search List. . . . . . : mycomp.com
                                            mycomp.com

Ethernet adapter Local Area Connection:

        Connection-specific DNS Suffix  . : mycomp.com
        Description . . . . . . . . . . . : Intel(R) 82567LF Gigabit Network Con
nection
        Physical Address. . . . . . . . . : 00-24-7E-DC-A4-A0
        Dhcp Enabled. . . . . . . . . . . : Yes
        Autoconfiguration Enabled . . . . : Yes
        IP Address. . . . . . . . . . . . : 205.142.113.181
        Subnet Mask . . . . . . . . . . . : 255.255.254.0
        Default Gateway . . . . . . . . . : 205.142.112.1
        DHCP Server . . . . . . . . . . . : 205.142.112.212
        DNS Servers . . . . . . . . . . . : 205.142.112.89
                                            205.142.112.103
        Primary WINS Server . . . . . . . : 205.142.112.89
        Secondary WINS Server . . . . . . : 205.142.112.103
        Lease Obtained. . . . . . . . . . : Tuesday, May 24, 2011 1:03:31 PM
        Lease Expires . . . . . . . . . . : Tuesday, May 24, 2011 9:03:31 PM
share|improve this question
add comment

3 Answers

Aside from making sure you have the right IP address, it is also important to make sure a firewall is not interfering. Firewalls may use a 'stealth' mode, where they drop packets instead of replying, which may result in the connection timed out message you mentioned receiving in a comment.

  1. Disable all firewalls.

  2. Test the connection, do whatever you need to do to get a working connection while firewalls are disabled.

  3. Open the correct port.

  4. Reenable the firewalls.

  5. Test again. If it only works with firewalls disabled, you probably need to fiddle with the opened ports. For troubleshooting, it helps to enable the firewalls one at a time so you can rule out working configurations.

openSUSE and Windows XP both come with firewalls. For openSUSE, you can access the firewall settings under the YaST2 Control Center, under Security and Users. For Windows XP, there should be something under the program menu (I can't remember off the top of my head). There should be numerous guides available for configuring these firewalls, if you need them, through a quick Google search.

Security suites often include their own firewalls (e.g. Norton, McAfee, Trend Micro, etc.). They will also need to be disabled/opened.

share|improve this answer
add comment

There are several networking modes available under VMware Player, but all of them provide an IP for your guest OS as well as networking connectivity with the host OS. So (just as if it were a separate physical machine) you just need to point to your guest's IP :)

In most flavours of linux (including OpenSuse) you can run ifconfig to see the IP address assigned to each interface.

share|improve this answer
    
just added output of ifconfig and ipconfig. They are even on different subnets. Will that be a problem? –  Learner May 24 '11 at 19:13
    
Depends, which networking mode are you using? It's under VM Settings. Check the networking device. –  Code Bling May 24 '11 at 19:18
    
If you're using NAT or Host-only, you're probably ok. If you're using Bridged then you have a problem. –  Code Bling May 24 '11 at 19:20
    
it shows NAT –  Learner May 24 '11 at 19:32
    
Should work then, just give her a go. –  Code Bling May 24 '11 at 19:38
add comment

I have VMware Workstation, which creates a new network on the host that the VM connects to, such as 192.168.206.x. Via DHCP, the host might get .1 and the guest .128, so you can send you message from the host to 192.168.206.128:10000 and have it get to the VM (which has to be listening on port 10000 of course).

VMware player should be the same if it creates networks, check the network connection properties on the guest or host to find the right IPs.

EDIT: Just saw your ipconfig output, try ipconfig /all or look in Control Panel -> Network Connections to see if there is "VMnet" adapter, with the same 192.168.206.x address.

share|improve this answer
    
added output for ipconfig /all. I can see two VMNet adapters in Network connectionss, their status is 'Connected, Firewalled' –  Learner May 24 '11 at 19:31
    
Ok, one of those will be the right one, it doesnt matter which. Try pinging your guest OS IP 192.168.206.128. If it works then you are in business. –  Spectre May 24 '11 at 19:36
    
@Spectre: Request timed out. :( I have also updated the question, (output of the ipconfig /all command, please have a look.) –  Learner May 24 '11 at 19:50
    
@Bhushan: check to see that the VMware driver is bound. Control Panel->Network Connections->Local Area Connection->Properties, then make sure the boxes beside VMware are checked –  Code Bling May 24 '11 at 19:53
    
@Code Bling: over there, box in front of VMWare Bridge Protocol is checked. Apart from that, I don't see any entry having VMWare in it. –  Learner May 24 '11 at 19:56
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.