Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just installed Debian 6.0.1 on a new machine today. It has a Intel DH67CFB3 motherboard and a built-in ethernet card which is the Intel 82579V. I googled around for a while trying to find how to install this ethernet card. This is what I have tried so far:

  • During install, tried selecting the "82579 generic module", didn't work
  • During install, tried selecting the "e1000 module", didn't work
  • During install, tried selected the "e1000e module", didn't work
  • After install ran insmod with path to e1000e module .ko-files, didn't work

I'm stuck at the moment and would appreciate some enlightenment!

Background info:

When I run ifconfig it only shows the loopback. Interfaces files only contain config for loopback When I run lspci -v, this is the info I get for the ethernet card:

00:19.0 Ethernet controller: Intel Corporation 82579V Gigabit Network Connection (rev 05)
Subsystem: Intel Corporation Device 2000
Flags: bus master, fast devsel, latency 0, IRQ 10
Memory at fe500000 (32-bit, non-prefetchable) [size=128k]
Memory at fe528000 (32-bit, non-prefetchable) [size=4]
I/O ports at f080 [size=32]
Capabilities: [c8] Power Management version 2
Capabilities: [d0] MSI: Enable- Count=1/1 Maskable- 64bit+
Capabilities: [e0] PCI Advanced Features

I obviously most have missed something, or am I doomed to not being able to use this ethernet card?

share|improve this question
    
When you ran insmod, did you use the full path to the ko files? And where did you obtain the ko files? –  evan.bovie May 24 '11 at 21:40
    
Also, what kernel are you using? And also post the output from lspci -nnk. –  evan.bovie May 24 '11 at 21:48
    
emb1995: Yes, I used the full path; "/lib/kernel/.../e1000e.ko", taken from ouput of "find / -name "e1000e". I'm not at the office right now, so I can't check. But I'll check in the morning! –  rzetterberg May 24 '11 at 22:54
add comment

1 Answer

up vote 3 down vote accepted

Since Debian 6 (Squeeze) did not originally come with support for the Intel 82579V NIC, a blogger came up with this guide. According to Intel's website, this e1000e driver should work, it's just that the driver version you have is old. I would suggest actually pulling the latest version from here, and building the modules on your machine so that you have the latest version module. The readme inside the folder has complete instructions.

All of this really occurred because of bad timing. This forum thread towards the bottom stated that:

The patch for this device was added just as 2.6.35 was closed. So you'll need a 2.6.36 kernel.

share|improve this answer
    
Thanks, it works fine now :) –  rzetterberg May 25 '11 at 15:14
    
+1 for referring to my blog :-) –  Linus Kleen Jun 14 '11 at 4:09
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.