Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I seem to have a bug someone where in my user profile that gives an internal error 2203 C:\Windows\Installer\6f5285.ipi, -2147287035

I am able to get around this by using another account and using runas, but this is awkward, and makes life difficult when I am trying to uninstall programs that are only installed for one user using control panel.

Does anyone have a solution to this problem?

Using Windows 7, UAC is on (off still generates the same error), and I get this when trying to install many programs.

share|improve this question
Does this only happen with your user account? Do you have another admin account that you can try? Can you use the built in administrator account to install this program? – Doltknuckle May 24 '11 at 22:44
Yes, that's why I created the other account. I can use the workaround described above, but I would like to fix the underlying problem. In addition, system restore did not fix the issue. – soandos May 24 '11 at 22:48
When exactly are you receiving this error and how are you installing the applications (script, by hand etc.)? – mrnx May 25 '11 at 11:48
You said that you had another account that used the runas command to run the program using the origonal "broken" admin account. That is not the same as using a second admin account. – Doltknuckle May 25 '11 at 15:38
up vote 3 down vote accepted

So from what I found on the internet is that this error message can be triggered by a few situations:

Situation 1 - NTFS Permissions issue

It is possible that the SYSTEM security user does not have permission to all of the resources needed to install the product. (source1, source2)

There could also be an issue with the permission on the %temp% folder. (source)

Situation 2 - User account Issue

It is possible that there is something wrong with the local profile of the user you created. Something as simple as having the wrong environmental variables could cause a problem. If this is part of a Domain, I would check the GPO settings for this account. If not, I would backup any user data in the profile and delete it. This should rebuild the profile and hopefully give it the proper settings. (source)

Situation 3 - Turn off Admin Approval Mode

In windows, Admin accounts don't operate with admin rights. You must escalate to an admin user in order to access certain protected areas. Even if you turn UAC off, this setting remains on. The only way I know of to turn this off is to go into the registry and modify the EnableLUA key.

Run Registry Editor (RegEdit) and navigate to the following registry key:


Locate the following REG_DWORD value:


Set the value of EnableLUA to 0.


Hope this helps

share|improve this answer
With regards to: 1) So I should use ICALCS on what exactly? 2) How do I go about doing that? 3) Isn't that a security issue? – soandos May 25 '11 at 16:36
@Doltknuckle: Is there a way to use the old settings in the deleted file with the rebuilt profile? – soandos May 25 '11 at 17:45
Method 1 only states that the error shows up when there is an NTFS permission issue. You don't need to use ICALCS for anything since the source document is is about office. Right click on the folders in question and inspect the security tab. make sure that your account and the SYSTEM account has access. – Doltknuckle May 25 '11 at 20:46
Method 2 is only if you are in a domain and have GPO policies in place. From your answer it doesn't seem like you are. As for the settings, the whole point is to revert to a standard configuration. You can generally copy the profile to another folder, but to get the settings back in, you have to know what files and reg settings you need to move over. – Doltknuckle May 25 '11 at 20:49
Method 3 is a security risk. I'm not suggesting that you turn it off forever, but that you turn it off for a short period. This is a test to see if the admin approval mode is causing the problem. You'd turn it back on once you figured out what is actually causing the error. – Doltknuckle May 25 '11 at 20:51

I just wanted to throw in how I solved my Windows Installer, error 2203 issue.

All of our firm's laptops are using folder/file level encryption.

I had to remove the encryption flag on the %temp% folder.

I can now install programs on this laptop.

share|improve this answer
That is the same as situation 1 in the other answer. – soandos Jun 6 '12 at 18:30

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.