Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My primary home machine loses network connectivity for a very brief moment once or twice a day. Here's what I've observed over the past few months:

  • Seems to happen every 12 hours after a restart
  • Disconnect is very, very brief. Putty sessions, online games, or other applications that require a consistent connection disconnect but it's rare that I can see a ping fail when everything else disconnects.
  • Does not coincide with network problems on other machines (Xbox/media PC/wife's PC).

Other details about my system and home network:

  • Windows 7
  • Asus motherboard (couple generations old) with onboard ethernet
  • Ethernet > wired hub > wireless router > cable modem (wife's PC is connected to the same hub and does not have the problem, at least not on the same schedule)

Things I've tried (and will probably now try again just in case)

  • Restore network card driver (I'm in the process of finding a specific one for my motherboard)
  • Tinkered with power saving settings in the ethernet card drivers.
  • Fully up-to-date Windows install.
  • Static IP address reserved by the wireless router running DHCP
  • I'm not 100% sure, but I think this problem persisted across Windows OS upgrades (from Vista to Windows 7 a few months back)

By far the weirdest part is that it seems to happen every 12 hours. Like clockwork, I can predict that I'm going to disconnect from any persistent online connection if I know the last time I restarted my machine.

Solved

I caused my own problem long ago when trying to set static IP addresses in my home. I have a Netgear Router (WGR614v9) and I played with the Address Reservation feature. In addition, I manually set the IP address I wanted to have on my machine using the normal network card properties. Setting the IP address manually is what seems to have caused the conflict.

Finally looked in the Windows Event Viewer and the culprit was quickly identified. At time of restart and every 12 hours later, the following error appeared:

The IP address lease 192.168.1.20 for the Network Card with network address XXXXXXXXXX has been denied by the DHCP server 192.168.1.1 (The DHCP Server sent a DHCPNACK message).

I accidentally fixed it for all affected machines by changing the start address of the DHCP server on the router (increased it from 20 to 30). That seemed to kick all the manual entries out and set them back to automatic obtain mode.

share|improve this question
    
try pings to your default gateway using .2 interval instead of 1. Also, is this wireless or wired? Have you tried the other and seen the same behavior (narrows down machine issue or network card issue)? What is your router's DHCP lease set to? Are you running through any other switching equipment? –  MaQleod May 25 '11 at 1:53
    
Wired going through the setup mentioned in the original question (hub > route > cable modem), only my machine has the problem. Using default Netgear web admin, I'm not sure if I can change the DHCP lease or not - I am using the "Address Reservation" feature of the router to keep a static IP for my machine though I'm now not actually sure if it's actually treated as actually static or not. Not sure how to set how often a ping happens using windows CMD ping or cygwin. –  Dave Hendler May 25 '11 at 2:01
    
The OS still considers it dynamic, and uses DHCP to get the reserved address, but you'll probably fine the lease time is infinite or until year 2038 or something if you look in ipconfig /all –  Spectre May 25 '11 at 15:58
1  
For the record, looks like my router sets a 48 hour lease. We'll see if anything weird happens tomorrow night. Also, Spectre - you should move your comment to its own answer so I can credit you with the solution. The very basic advice of "Check the Windows Event Log, idiot" is really what I needed. –  Dave Hendler May 25 '11 at 23:37

1 Answer 1

up vote 2 down vote accepted

If this a bog standard install, I would say this is down 100% down to network card driver, try taking a look at chipset vendor sites such as Realtek or Intel for a driver.

If however you have any custom firewalls or monitoring software, it may be worth a check as it could be some sort of internal maintenance task which is resetting the network interface on a timer.

share|improve this answer
    
Just installed the latest driver for the NIC. I'll post back in 12 or 24 hours to see if it helped after the latest restart. –  Dave Hendler May 25 '11 at 1:23
1  
It smells of a DHCP problem, and still could be even though you set reserved IP in the router. Typically renewal of a DHCP lease should be seamless, the OS requests the same address before/on the time of lease expiry, and provided the router gives the same address, there shouldnt be a disconnect. Maybe this process is failing and the OS is making a full request for a new IP address. Check your Event Log for networking/DHCP info/warnings/errors around the disconnect times, also your routers log if it has one. –  Spectre May 25 '11 at 15:55
    
Spectre, you nailed it! Event log shows DHCP errors every 12 hours. At some point fairly far in the past I was trying to set a static IP address directly in the NIC properties and there's a "lease denied" error that coincides with restart time and every 12 hours. I think the network card driver update reset my custom settings and may have fixed the problem. Will now at about 9:15 at the next 12 hour checkpoint. –  Dave Hendler May 25 '11 at 23:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.