Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I'm browsing the Internet every time I type a page or follow a link, the browser always waits for a few seconds on "Sending request... " "Looking up... " or sometimes "Waiting for... ".

This happens when I'm using Firefox or Chrome. I recently ran a cable to see if wireless was the issue but it isn't.

This happens on Windows 7, Ubuntu 11.04 and Fedora 15, so I'm fairly sure it's a router issue.

I've tried changing my DNS servers on the router from my ISP's to whatever Namebench recommended (First was Google, second was OpenDNS I think).

It's not just a slow connection, because my sustained download speed on BitTorrent, SpeedTest etc is pretty fast.

enter image description here

I'm usually quite a technical guy but this has really got me stumped.

share|improve this question
1  
So if you ruled out individual machines and DNS, then it will probably be the router itself. Are you using a cable modem too and which models do you own? – slhck May 25 '11 at 7:05
    
@slhck it's an ADSL modem built into the router - My ISP (Orange) sent me the router (Netgear DGN1000) but I had it with my old ISP (O2) at the same address, with a different router. – Rory May 25 '11 at 8:00
1  
"Looking up" is the DNS delay. Be careful with Google/OpenDNS. I find its best to keep the ISP provided DNS as the primary DNS, with Google/OpenDNS as the secondary. Your ISPs DNS normally has a much lower latency, and also helps you get to content cached by your ISP for increased browsing speed. – Spectre May 25 '11 at 15:37
    
well you could use wireshark see if anything stands out re DNS – barlop Sep 5 '11 at 2:22

Have you checked the ping time on speedtest.net? The most likely problem is latency in your case, which has a major impact on performance.

Another metric to watch for is upload speed. I have a fast internet connection (50 Mb/s) but the bad part is the upload speed is pathetic (2 Mb/s), making overall browsing slower than I'd like.

share|improve this answer
    
+1 for mentioning different types of tests (and congratulations on reaching 10,000 points). – Randolf Richardson May 25 '11 at 7:23
    
Thanks, but my ping time is respectable. Take a look at the Speedtest link to see my results. My upload speed is 1Mbps which is enough to send the small amounts of data required to request a webpage. – Rory May 25 '11 at 7:23
    
@Blazemore: what exactly does respectable mean? – alex May 25 '11 at 7:24
    
@RandolfRichardson: thank you! It took me a while to get to 10k :) – alex May 25 '11 at 7:25
    
@alex it means it was 36ms on that test, and I never get lag in online games. It seems to only be DNS lookups that have the issue. – Rory May 25 '11 at 7:26

Have you tried giving yourself a static IP address?

It sounds like it's a DNS lookup problem so maybe have a search around for that. I found this bug report and it's worked for a couple of other people with the same problem as you so give it a go.

If that doesn't work, try borrowing a spare router from someone else to test if it really is a router problem.

share|improve this answer
    
Do you mean a static IP from Orange, or give my computer a static IP (bypassing DHCP)? If you mean the latter, I don't think that's an issue since it occurs to all devices connected to the router. If you mean the former, Orange charge a fortune (probably) for static IPs. Do you have a spare router? Don't forget it's ADSL so you can't just drop one in. It would have to be reconfigured for my ISP, or if it was a cable modem, I'd have to reconfigure my current router to act as a straight ADSL modem. I have a Linksys cable router in a cupboard but I don't know how to use my Netgear as a modem. – Rory May 26 '11 at 8:25
    
I mean just give your computer a static IP. I can do it on Windows, not so sure on Linux but I expect you know how to. You're right, it may not work, but it's worth a try. As far as routers are concerned, I don't have an Orange one, but someone else at Uni might do. You could just try plugging your Linksys one in and give it a go. I've done that with BT as my ISP and it worked. – Nick Brunt May 26 '11 at 16:02

One possibility is IPv6. Maybe your PC tries AAAA (IPv6 address record) queries first, and falls back to IPv4 after a timeout. What OS do you use?

share|improve this answer
    
As I said, it happens on Windows 7, Ubuntu 11.04 and Fedora 15. Both wired and wireless (different adaptors) so it's not some kind of driver or even firmware issue. – Rory May 25 '11 at 7:59
    
If AAAA queries are timing out, then the DNS server is broken. My system tries IPv6 first, too, but the DNS queries properly result in an empty reply, in milliseconds. – grawity May 25 '11 at 8:20
    
My OS at the moment (Ubuntu) is set to ignore ipv6 – Rory May 25 '11 at 8:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .