Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running Bitnami on my free tier amazon

bitnami-lampstack-3.0.6-0-linux-ubuntu-10.04-ebs (ami-aa8cf5f8)
Description:    BitNami Lampstack 3.0.6-0 EBS AMI
Status: available
Platform:   Ubuntu
Image size: 10 GB
Visibility: Public

Anyway I'm trying to install a web console that will allow me to administer it, you know add new virtual hosts to apache, add new users to unix, administer the database etc. I decided on webmin.

Ran the install for webmin and it setup fine, however, it does not read the fact that apache, php, mysql etc are installed.

That's because the path it looks for them is wrong - bitnami does this thing where every file is installed in the /opt/bitnami folder. So I went and changed all the settings in the apache module config. Webmin gives this error

The Apache server executable /opt/bitnami/apache2/bin/httpd does not exist. 

The thing is, that the file there does exist. But I try running it through SSH i get this error:

error while loading shared libraries: libaprutil-1.so.0: cannot open shared object file: No such file or directory

Okay.. so what I'm thinking is maybe i'm linking it to the wrong file, after all the default file is for webmin config is /usr/sbin/apache2. Does anyone have an idea of what needs to be done to rectify this?

Perhaps someone who has tried such a thing on bitnami before?

Thanks

share|improve this question

1 Answer 1

up vote 2 down vote accepted

It is necessary to edit the following files to manage the BitNami servers:

/etc/webmin/mysql/config

date_subs=0
max_text=1000
perpage=25
stop_cmd=/etc/init.d/bitnami stop mysql >/dev/null 2>&1
mysqldump=/opt/bitnami/mysql/bin/mysqldump
nodbi=0
mysql_libs=/opt/bitnami/mysql/lib
max_dbs=50
start_cmd=/etc/init.d/bitnami start mysql >/dev/null 2>&1 &
mysql_data=/var/lib/mysql
mysqlimport=/opt/bitnami/mysql/bin/mysqlimport
access=*: *
style=0
my_cnf=/opt/bitnami/mysql/my.cnf
mysqlshow=/opt/bitnami/mysql/bin/mysqlshow
mysql=/opt/bitnami/mysql/bin/mysql
nopwd=0
add_mode=1
passwd_mode=0
blob_mode=0
mysqladmin=/opt/bitnami/mysql/bin/mysqladmin

/etc/webmin/apache/config

link_dir=/opt/bitnami/apache2/conf/sites-enabled
test_manual=0
show_list=0
mime_types=/opt/bitnami/apache2/conf/mime.types
access_conf=/opt/bitnami/apache2/conf/access.conf
auto_mods=1
stop_cmd=/etc/init.d/bitnami stop apache
virt_file=/opt/bitnami/apache2/conf/sites-available
test_apachectl=1
max_servers=100
srm_conf=/opt/bitnami/apache2/conf/srm.conf
httpd_dir=/opt/bitnami/apache2
start_cmd=/etc/init.d/bitnami start apache
show_order=0
test_always=0
httpd_conf=/opt/bitnami/apache2/conf/httpd.conf
defines_file=/opt/bitnami/apache2/bin/envvars
apachectl_path=/opt/bitnami/apache2/bin/apachectl
show_names=0
test_config=1
apply_cmd=/opt/bitnami/bin/apachectl graceful
httpd_path=/opt/bitnami/apache2/bin/httpd

Then "Refresh the Modules" and you can see MySQL and Apache in the "Servers" tag.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.