Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My Windows XP doesn't have the synchronization tab under Control Panel > Date and Time settings. I tried to change the related registry settings, and it worked only for my Windows 7. What else should I try?

share|improve this question
up vote 7 down vote accepted
  • Make sure the Windows Time (w32time) service is running. (Either through services.msc, or sc query w32time and sc start w32time.)
  • Try running w32tm /register as an administrator.
  • Try manual configuration: w32tm /config / /update
  • ...and manual resync: w32tm /resync
  • Also open eventvwr.msc and check the Application and System logs for errors.
share|improve this answer
I didn't work before for 2 reasons: 1) the site was redirected by the corporate proxy to nowhere and 2) the updated time didn't show until I changed the time manually – Jader Dias May 25 '11 at 16:18
@Jader: You didn't mention you are on a corporate network. If your computer is part of an Active Directory domain, it has been already syncing to the domain controller. (If the time difference between DC's and workstation's clocks is too big, domain authentication will not work. Besides, when workstations sync to the controller, there is only one place for the admin to configure.) – grawity May 25 '11 at 17:26
I suspect the AD is unsynchronized with the rest of the world. So I had to make a workaround. – Jader Dias May 25 '11 at 17:49
@Jader: That might be the case, but it's possible that your "workaround" might break domain logins for you. IIRC, the Kerberos protocol can tolerate up to +-5 minutes in the default configuration, but be careful anyway - and ask the domain admin to fix clocks. – grawity May 25 '11 at 17:58
It worked like a charm for me, thanks! And I have to add that I use: as a server, if it is any help. – ramayac Jul 30 '11 at 18:34

Quick note for anyone who comes across this solution in the future -- if the command above doesn't work, add /syncfromflags:manual in there as well like this:

w32tm /config / /syncfromflags:manual /update

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .