Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running Windows 7 and am trying to connect to a specific IP on a VPN network that I'm connected to.

Since I don't want all Internet traffic to go through the VPN connection and I want to be able to run a server on my normal IP, I have unchecked the "Use default gateway" option on the VPN connection.

However I am now unable to reach any IP on my VPN network. After searching Google I found that this could perhaps be solved with persistent routes, but my attempts at trying this didn't work.

Any ideas how I can achieve this?

share|improve this question

1 Answer 1

Open up the Network Connections view via control panel/network and sharing centre, right click on the VPN connection, and select Properties. Then go to the Network tab, and select IPv4, and then Properties. Then click the Advanced button, and untick Automatic Metric. Enter in a fairly large number (I use 9000), and then OK your way out of all the dialogs (you may want to do the same with IPv6 if your VPN supports it).

Here's a screenshot from my desktop PC with VPN:

enter image description here

The Metric value determines the order in which Windows tries networks in order to access a resource. Normally on automatic, Windows tries to use the connection with the fastest connection speed, but this can sometimes be wrong (eg wireless N being used instead of 100Mbit lan, or VPNs getting prioritised when they shouldn't). Setting the higher value means the connection is less favoured, and Windows will only try and use it when you request resources (remote LAN IP addresses) that can't be resolved by other connections.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.