Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

one of my coworkers installed IE9 on their computer. They are now having trouble accessing some websites that once worked(and still work) in other browsers.

One example is this page: https://secure.projectmanager.com/login.aspx

In Firefox and Chrome, there is no certificate error and the certificate is verified and such. In IE9 it will say "Certificate Error: Navigation Blocked". When pressing the "continue to site" button though, nothing changes, it just stays on the same page. We've tried adding the site to trusted sites, but nothing is helping this.

Is this a bug in IE9 or is there error elsewhere?

Also, it's not a cache issue because this is the first time accessing that site from that computer. And that site works fine from Firefox and Chrome on that computer, and works fine from IE8 on my computer.

share|improve this question
    
Unsure if anything has changed since you posted, but I had no issues viewing the page without errors on my computer with IE9. –  edusysadmin Jun 3 '11 at 18:53
    
Is your IE9 configured other than default by MSFT? –  Ram Sep 28 '11 at 22:40
add comment

5 Answers

  • Make sure your PC's date and time is correct.

  • You may also follow these steps and check if it helps.

    1. Type ‘inetcpl.cpl’ in the start search box.

    2. Click on contents tab.

    3. Click on certificates.

    4. Click on ‘Trusted Root Certification Authority’ tab.

    5. Select the website name and click on ‘Remove’.

    6. Restart Internet Explorer & try to access the website.

  • Do an IE reset: go to Internet Options, Advanced Tab and hit the reset button.

    Reset Internet Explorer settings

More suggestions

share|improve this answer
4  
Just to update, I've tried this and the only solution for us was to just use another web browser –  Earlz Jul 18 '11 at 16:46
add comment

This is simply fixed

  1. Browse to the site whose certificate you want to trust.
  2. When told "There is a problem with this website's security certificate.", choose "Continue to this website (not recommended)."
  3. Copy the entire URL from the command bar.
  4. Select Tools->Internet Options.
  5. Select Security->Trusted sites->Sites.
  6. Paste the URL in the box provided
  7. Confirm the URL matches, and click "Add".
  8. Close the "Internet Options" dialog box.
  9. Refresh the current page. If the error persists you may need to restart explorer.
share|improve this answer
add comment

The problem has been caused by Microsoft Security Update for Windows 7 (KB2585542) If you uninstall this update the problem is fixed.

share|improve this answer
add comment

I encountered these same symptoms once when a bad root certificate was installed for a site. A Microsoft SBS2008 had recreated its local CA root certificate for unknown reasons and automatically renewed its SSL certificate with that, but the remote clients still had the old root certificate installed.

Trying to install the new certificate over the old one did not work. The certificate wizard displayed a "success" message but there was still only the old one installed. After forcibly uninstalling the bad root certificate and then installing the good one, the problem was gone.

share|improve this answer
add comment

That made the trick for me, enjoy :)

http://corengen.wordpress.com/2012/10/11/internet-explorer-unable-to-display-webpage-after- applying-windows-update-kb2661254/

share|improve this answer
    
A better answer would provice the key parts of the post you link to. As links often change, the answer becomes less useful or not at all useful to future visitors –  Dave M Jan 28 '13 at 15:56
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.