Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I don't know why, but some of the equations in my Word 2007 document just won't print. They are left blank in the actual print, despite being correctly shown in the Print Preview.

The same happens if I try to convert the document to a PDF file using the virtual Adobe Acrobat printer.

In both cases missing equations happen to be on pages where some picture has been inserted (which displays fine, by the way).

Trying to export to PDF using the built-in converter gives even worse results - all equations are missing.

Do you have some clues what could be causing such issues?


As requested here are some sample files. I've stripped all non-essential text, but it should be sufficient:


The thing is - I suspect it's some kind of a font issue. I was forced to find a workaround as the matter was rather urgent. Fortunately, the document printed correctly when opened on another computer. But the math font looked differently after printing to PDF (though good enough to be acceptable).

What I can't understand is why removing graphics (Excel charts, pictures etc.) from the page solves the issue in the original faulty environment.

share|improve this question
    
Pczak: Can you provide a sample .docx file which shows the behavior? (Boil it down to 1 page, if possible). Can you also provide a PDF with such a missing equation? Without looking at the actual file(s) the answers will be pure speculation (unless someone else has seen the exact same problem and solved it).... –  Kurt Pfeifle May 27 '11 at 4:43
    
@pipitas: Sure, I will update the question accordingly. –  Karol Piczak May 27 '11 at 10:15
    
D'uh, I was so focussed on the details, that I missed to notice that you already stated it was a Word 2007 file... (LibreOffice 3.2 cannot open it correctly and display the formulas, BTW.) –  Kurt Pfeifle May 27 '11 at 13:20

6 Answers 6

up vote 4 down vote accepted

Today I have the same problem with exporting Word 2007 equations in PDF using save as -> PDF. Recently I was using doPDF to export Cyrillic texts and I decided to try it with the word equations. It worked perfectly!

Referencing another forum discussion in acrobat users blog I found the real word solution - simply load the “Files for Complex Script and right-to-left languages” found under the "Languages" tab in Regional and Language Options in the control panel

You will need a Windows XP SP3 CD and restart. The Saving the docx as PDF after this manipulation works perfectly!

share|improve this answer

Looking at the Metadata of your files it seems that...

  • ... the .docx files were created with MS Office 2007 (or later)
  • ... the .pdf files were created with Adobe Acrobat Distiller 8.0.0

AFAIR, Acrobat 8.1 (released in June 2007) was the first Acrobat version to support MS Office 2007. So my guess is that the faulty PDF (missing the formulas while this other graphic is also present) is due to Acrobat 8.0 not being up to the job.

I do currently have no MS Office 2007 or later around to open the original file. I only have Office 2003 on Win XP. If I open the .docx there, the file gets somehow converted to an earlier version, and the formulas get converted to low resolution graphics -- yes, even inside the opened .doc(x) -- and they are no longer editable....

The Acrobat 9.4.4 present on the same XP system can convert to PDF both *.doc(x) files opened in Office 2003 just fine (but the formula graphics are clearly low-resolution quality).

OTOH, Office 2007 may already have a built-in method to convert/save as its documents in PDF format (Office 2010 definitely has this). Maybe this gives you better PDF results than relying on a Distiller 8.0.0 from a time that was just before your *.docx newness even hit the market?


Update: Later this weekend I'll be able to open the *.docx files in Word 2007 and see what can be done for the PDF conversion from there...


Update 2: I've now had the opportunity to look at your original .docx file. My friend's system was a Vista, with Office 2007 and Acrobat Professional 9.4.0.

With this software combo, there are 3 different ways to create a PDF from the .docx. From the application main menu click on...

  1. "Print..." and select the "Adobe PDF" printer. This generates a PostScript file and sends it to Adobe Distiller which converts the PS to PDF.
  2. "Save As..." and select "Adobe PDF". This path uses the 'Adobe PDFMaker for Word' set of macros (which come onto the system with the Adobe Professional install routine) and convert to PDF without the PostScript de-tour.
  3. "Save As..." and select first "PDF or XPS", then "Save as type: PDF". This method is the built-in MS way to convert Word files to PDF.

I tested all 3 methods, and each of them had as a result the math formulas on the PDF page in good quality.

I noticed that the font used inside the formulas is Cambria and Cambria Math. Karol, you should check your one system which doesn't produce the formulas in the PDF: does it have these fonts installed?


Update 3: Since your two systems which produce different PDF results from the same input .docx file via "Save As... --> Adobe PDF", one thing to check are the PDF conversion settings used on both systems.

From the top of my head:

  1. Click on Acrobat in the top menu of the Ribbon Bar.
  2. Click on Preferences.
  3. Check which selection is active in drop-down menu of Conversion Settings.
  4. Check all the other settings (maybe document them with screenshots).
  5. On the Settings tab, click on Advanced Settings....
  6. Check all the settings (maybe document them with screenshots).
  7. Click on Save As.... This will be an ASCII text file with the suffix .joboptions. It holds (nearly) all of the Distiller settings used for producing the PDF.
  8. Choose a filename you can remember and match to the host where you created it.

Follow this procedure on both your systems. After you created the two .joboptions files, compare them with the help of a text editor of your choice.

I'm quite sure you'll discover some differences. (Maybe not the ones which are responsible for your problems, but it's worth a try...)

Apologies if my memory failed me and if parts of above procedure is not entirely correct....

share|improve this answer
    
Thanks, it is probable that Acrobat 8.0 has some issues. But it's the first time I have some problems with it on Word 2007. I've added some additional files. As you can see on the faulty workstation the built-in exporter does have similar issues. On my netbook I've managed to "save as PDF" with all equations visible, but they seem to get converted to lower quality graphics (not selectable in the generated PDF). The Distiller gives better results in general, but in this case the non-rendering issue makes it unacceptable. –  Karol Piczak May 27 '11 at 15:29
    
I'm still trying to pinpoint what could be causing this. Unfortunately, I don't have access to a newer Adobe Acrobat version. So testing this path is not possible at the moment despite being the most promising way. –  Karol Piczak May 27 '11 at 15:32
    
Unfortunately the fonts are available, so this should not be a problem. I'm afraid this is one of those hard to reproduce configuration specific issues. Thank you for all your help on this. I will mark this answer as accepted, though I haven't found a real solution yet. Nevertheless, you've helped me confirm that this is a single system issue. At least for the time being, I can switch to some other station for final printing until I find the underlying cause. Once again thanks for the input. –  Karol Piczak May 30 '11 at 17:23
    
@Karol Piczak: Don't mark the answer as accepted, if it doesn't provide a real solution. Limit your favor to a simple upvote then :-) –  Kurt Pfeifle May 30 '11 at 20:20
    
I doubt that in cases like this you can find a specific solution other than by accident. Knowing it's a unique configuration issue is good enough for me. Probably reinstalling all from scratch would (could?) help. If you're feeling uneasy about this, you may rephrase your answer to "can't reproduce, works by me, try repairing your system". ;-) Which is a valid hint by the way. If I happen to pinpoint the underlying cause somehow (doubtful, but nothing is impossible), I will post it here and move the acceptance mark. :-) –  Karol Piczak May 30 '11 at 20:32

This problem may occur for a paragraph which contains only equation and has text direction of Right-to-Left.

The solution for such case is either:

  • Change text direction of the paragraph (which contains only equation) from Right-To-Left to Left-to-Right.

  • Add some text to Right-to-Left paragraphs that contain equations (bullets or numbering is enough)

share|improve this answer

I've managed to find a working solution to this problem. I don't know really why it behaves like this, but I've come across a similar topic (Acrobat v8 doesn't like Cambria) on the Adobe Forums.

The fix suggested by jallisy in the original topic:

Do you have XP for OS? Here is the Microsoft solution

Try the steps mentioned below and check if that helps:

Windows XP > Control panel > Regional and language options > Languages tab > check the box for 'install files for complex script' and click on apply.

does indeed work in my case.

After applying this and restarting, the faulty system behaves the same as the netbook. Using the "Save as PDF or XPS" I get the equations displayed correctly, though in a bit lower quality (exactly the same behavior as on the other system).

However, the Acrobat Distiller (virtual printer) does now generate high-quality selectable equations both for pages without graphics (which it did before) and pages with accompanying graphics (which was not working correctly).

To be honest, I have no clue why there's such a quirk, but I'm glad it gets resolved in the presented manner.

share|improve this answer
    
Ah, I'm glad this issue is resolved for you. (Didn't see it at first, since I had this page open for a few ours in a tab before I came round to update my answer.) –  Kurt Pfeifle May 30 '11 at 22:26
    
Oh, my bad, only now did I see that @Димитър provided the same solution in an edit yesterday. I've missed that earlier. –  Karol Piczak May 31 '11 at 13:29

Save file as open text document (odt), open saved file with OpenOffice.

This worked for me while the other answers here weren't applicable (because I'm using windows 7 and not XP).

share|improve this answer

The answer for these problems are: Decrease (reduce) the quality of pictures (not only change the size of picture in the Word file. I mean move the corner of picture) in your page which include missing equations by using any photo software. I think because of RAM not enough.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.