Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a computer running Windows XP. I am trying to run the Arduino IDE 0022. I double-click on arduino.exe, it waits about 30 seconds on the load up title screen, and then it gives me this error:

Launch 4j: an error occurred while starting the application

My only choice is to click "OK"; the error goes away, and the Arduino IDE closes. If I try to delete the Arduino files (to try overwriting with some different files), I get an error that doesn't allow me to do so:

Cannot delete awt.dll: Access denied

Make sure the disk is not full or write protected and that the file is not currently in use.

The only way to delete the file is by restarting the computer. So something must still be trying to run after that first error.

I have noticed in Task Manager that some Java programs are still running: javaw.exe (3 processes)

I think this is a problem with Java, but I checked and updated all of my Java software and it is all up to date. I have looked on other forums for this issue and none of them seemed to help. From the forums I have tried:

  1. Different Arduino IDE versions
  2. Updating Java
  3. Opening arduino.exe as Administrator

Nothing has worked. Anyone have any suggestions?

share|improve this question

migrated from May 25 '11 at 20:09

This question came from our site for professional and enthusiast programmers.

@John Did you remove all of your sketches from your user folder before opening? – evan.bovie May 25 '11 at 20:31
I haven't written any new sketches, if that's what your asking. As soon as I downloaded the arduino program I tried opening it and this is what happens. I can't get to an empty sketch to even write a new one. – user83321 May 27 '11 at 19:47

The same thing happened to me; I tried a huge number of different suggestions to fix this.

Eventually I switched any read-only files in my c:\Users\%User%\AppData folder to write-enabled and any problems I was having with Java (in processing and the Arduino IDE) disappeared.

share|improve this answer

I tried pretty much all suggestions I could find scattered in various forums without luck.

The one thing that eventually worked for me (with Arduino 1.5.6-r2 Beta) was to replace the [arduino_root]/lib/jna.jar version (3.0.3 b2) that comes with the Arduino IDE with another version (3.2.7) that I had laying around from an installation of the Gradle build tool.

share|improve this answer

I also had this problem.

Something that worked for me : delete the folder c:\Users\%User%\AppData\Roaming\Arduino15.

And it's starting again!

share|improve this answer

You must log in to answer this question.

protected by Community Mar 28 '15 at 19:06

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?