Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have Windows 7 RTM, Office 2007 SP1, and a computer with English and Hebrew languages installed. In most programs (e.g. notepad), Left Alt+Shift switches from Hebrew to English and vice versa.

In Word, it also usually works, but sometimes pressing Left Alt+Shift just won't do anything.

Is this a bug in Windows? Word?

share|improve this question

I had the same problem but then I found out that in Windows keyboard settings I've added another keyboad (Serbian) under English (United States), and not beside it. So I vent and set it all up again the right way and now it works. So instead of:

English (United States)

  • Keyboard

    • US
    • Serbian (Latin)

Now I have:

English (United States)

  • Keyboard

    • US

Serbian (Latin)

  • Keyboard

    • Serbian (Latin)
share|improve this answer

Works for me, at least. You can try changing the keystroke to switch input languages in

Regional and Language Options > Keyboard and Languages > Change keyboards > Advanced Key Settings.

Maybe a different combination might work.

share|improve this answer
    
Works for me too. Seems rather strange. – alex Aug 25 '09 at 10:28

In Regional and Language -> Advanced Key Settings, create a shortcut like Ctrl+0 to change to Hebrew (not between languages).

share|improve this answer

This happened to me recently. Tried the switch, nothing. Tried again, worked fine. Guess it's a bug (I'm on W7 RC).

I'd recommend trying the alt+shift method, then (if necessary) doing the slow way through regional options. I think this might re-enable the hotkey method.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .