Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an issue with my desktop icons on Windows 7. It seems that downloaded files or any files made by programs are sometimes placed on the top left of the desktop, shifting all of my existing desktop icons.

In Windows XP such icons always went to the bottom right. Is there anything I can change that lets you always have everything appear in the bottom right of the desktop icons?

share|improve this question
1  
What are your Sort By and Auto Arrange set to? Right click the desktop and hover over (or click I guess) View and Sort By. –  Hello71 May 26 '11 at 2:46
    
When you right click on the Desktop and click on View, check to make sure that both Auto arrange icons and Align icons to grid are unchecked. –  Moab May 26 '11 at 14:17

1 Answer 1

Windows is probably sorting your icons by Name - so if you right-click the desktop, and choose Sort By->Date Modified it will add the new items after the existing ones.

As for the bottom right corner - I never encountered that behavior.

Another option is to install Fences - It will arrange the constant icons on your desktop in such a way that the non-constant Icons will not interrupt.

Also - consider that a desktop with many icons is usually not that effective for usage, perhaps a Launcher can help you.

share|improve this answer
    
Thanks everyone, and Sort by Date Modified fixed it. –  Jeff Kang May 27 '11 at 2:55
    
Good to know, please mark the question as helpfully. :-) –  RonK May 27 '11 at 8:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.