Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I installed Ununtu 10.10 on a Lenovo Think Pad. I love it overall, but I for this crazy mouse problem. First a bit about the laptop.... It has both a track pad and a eraser mouse.

So after working with the laptop for a bit the mouse will just go nuts. It moved all over the screen without touching it at all. It isn't a deal where it hit it when I'm typing or anything like that. Once the mouse start moving all over the screen the only way I can stop it is to disable the device by using the commands...

xinput list
xinput set-prop 16 "Device Enabled" 0 

Then that will disable the trackpad, thus the wild mouse stops moving. I can then just use the eraser mouse from that point on. The deal is I hate the eraser mouse so I would love to get this corrected. I have done a lot of research on this error and I can't find a solid solution that actually works. My best guess is its related to the trackpad being disabled when I type and then when I come back to use it (I stop typing) something goes wrong and the mouse freaks out.

One last thing, I'm new to ubuntu so please explain any driver configs or command line stuff thoroughly.

share|improve this question
    
Do you know what causes the problem (when it goes from working to jumping)? –  soandos May 26 '11 at 3:40
    
I've seen similar behaviour before when a PS/2 mouse goes "out-of-sync". It might be an idea to confirm if the trackpad is an internally connected PS/2 device as far as the laptop/os is concerned. To do that we'd need to see the output of your PCI device listing. "lspci" is the command that will do that. Use www.pastebin.com to show us the output. –  camster342 May 26 '11 at 4:22
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.